X220s Voltage Indicator Help

betaflight
battery
fpv

#1

So i recently bought an Eachine Wizard X220s from banggood, its arrived in good time and seems to fly well enough. The problem i am facing is Voltage indicator, i plugged it into betaflight after installing all of the correct drivers and flashed the omnibus firmware onto the drone, no voltage showed up before or after flashing the firmware and when i check the battery tab it says that no power source is connected even when i plug the battery in. I have taken the drone apart and re-soldered the Vbus terminals to make sure they make good contact i also tried soldering the wires directly to the lipo terminals but still nothing. I am running out of ideas here please help. Any ideas would be helpful, thanks.


#2

https://blog.dronetrest.com/wizard-x220s-initial-setup-guide-in-betaflight/

It’s under the section heading: Enabling Vbat for OSD :grinning:


#3

Tried that but it doesn’t work


#4

have you used a volt meter to check the vbat pads are getting the lipo voltage ?


#5

unfortunatly i don’t have a volt meter to check, i am thinking about sending it back for a replacement because i have already destroyed one of my 4s batterys.