Wizard x220s r-xsr and fport

Hello guys!

Well moving on from my last post where I complaint about a failure in the r9mm reciever, and following @DoomedFPV adviced, I just moved to a r-xsr.
Reciever arrived, and I wanted to use fport. I updated firmware from frsky website to the latest fport firmware, I modified the tiny jsh connector from the reciever so I only have gound, 5v, and smart port.
Cool. Supposedly fport can be run from any spare UART. the wizard x220s has a omnibus f4 v3, so i wired ground to any ground pad, 5v to a 5v pad and smart port cable to UART 3 at first. Enabled serial rx on port 3 in port tabs in BF, but bars weren moving in the transmitter tab. i started playing with the half_suplex and noninversion commands, and tried all possible permutations and didnt work.
Then I moved from UART 3 to UART 6 and see if taht solved the problem… But no… it didnt.
Finally googleing and googleing, I ended in a post that adviced to conect the smart port to the sbus pad after having done the “un inversion hack”.
Aparently this SBUS pad is connected to UART 6, so activating serial rx in port 6 eventually I got signal, bars were moving, and I am able to arm and fly the drone.
Problem is… Im not getting any telemetry!!
Does anyone know what am I doing wrong??
Thank you!

my first question would be… have you turned it on?

Also have a read of this guide and see how you get on…

Thnaks for your reply…
And yes… I checked telemetry was enabled, and I read throughout Oscar Liang guide, and followed all steps.

if it helps ill post my diff from cli…



Betaflight / OMNIBUSF4SD (OBSD) 3.5.7 Mar 15 2019 / 22:11:36 (e9130527c) MSP API: 1.40

board_name OMNIBUSF4SD



resource MOTOR 4 A01
resource MOTOR 5 NONE



servo mix


feature RX_SERIAL
feature RSSI_ADC
feature DISPLAY
feature AIRMODE





serial 2 2048 115200 57600 0 115200
serial 5 64 115200 57600 0 115200





aux 0 0 0 1350 2100 0 0
aux 1 1 1 1300 1700 0 0
aux 2 13 5 1675 2075 0 0
aux 3 36 4 1700 2100 0 0
aux 4 39 2 1300 2100 0 0






set acc_calibration = -14,84,-239
set rssi_scale = 180
set rssi_offset = -100
set serialrx_provider = FPORT
set motor_pwm_protocol = DSHOT600
set small_angle = 180
set osd_rssi_alarm = 25
set osd_vbat_pos = 2134
set osd_rssi_pos = 2116
set osd_altitude_pos = 2484


profile 0

set dterm_notch_cutoff = 0
set p_pitch = 58
set d_pitch = 22
set p_roll = 43
set i_roll = 40
set d_roll = 20
set p_yaw = 70
set d_yaw = 5


rateprofile 0

set roll_rc_rate = 143
set pitch_rc_rate = 175
set yaw_rc_rate = 152
set roll_expo = 12
set pitch_expo = 12
set roll_srate = 74
set pitch_srate = 71

thank you veyr much beforehand!

Damn I was hoping for a easy fix…

I’ll have another look

@DoomedFPV. Thanks for your help…
At the end it was an easy fix… Im just stupid… I dont know what I have done differently from previous times… But… I just desoldered fport wire from SBUS pad (that was giving me channels comunication with transmitter, but no telemetry) to UART 1 Tx. Couple permutations with halfduples and noninversion commands, and voila! Channels and telemetry. Just like that
xDD Anyway thanks for your time! Cant wait to go out and fly it! thaanks you!