Turnigy 9XR Pro not talking to LibrePilot

librepilot
cc3d

#1

So I finally have all the parts needed to get my Eachine 250 Racer up and running.
A Frsky DJT ACCST module connected to my Turnigy 9XR Pro controller and a Frsky D4R-II 4CH Receiver. I bound the 2 together no problem and am running PPM

I went through all the steps in LibrePilot just fine for the quad itself, but once I get to the Setup Transmitter Wizard section, nothing is registered when I move the sticks.

It seems this isn’t a problem for anyone else, so what am I missing?


#2

I assume you have already verified the PPM output is working via another FC?

Have you checked the hardware tab to manually select your receiver port to be PPM mode? And that you RX is connected to your cc3d board as shown in the picture below?


#3

I would, but sadly I have but the one flight controller.
Yes I have manually selected ppm in LibrePilot. I chose the ppm with no oneshot and it is wired correctly.


#4

OK, so playing around a little bit I decided to hook up my receiver in PWM and went through LibrePilot and low and behold my transmitter actually registered movement.
So why isn’t my receiver working in PPM? It is plugged in correctly and the jumper is on the signal pin of 3 & 4


#5

At least you could times the receiver is working :-). But as for ppm that is a strange one… are you sure it’s connected tot he first input on your cc3d?


#6

Silly question time

Do you have to set the Receiver up to output PPM via the TX or do those receivers output PPM & PWM at the same time.

I only have Turnigy receivers and they have to be told what to output via the TX, could yours be the same?


#7

Wish I knew exactly. From what I can tell with my transmitter, it is setup as ppm by default.

As for the receiver, yes I’m very sure it’s connected to channel 1. I tried connecting to channel 2 just to be sure and the quad wouldn’t even chime on till I put it back in channel one


#8

Lo and behold, I have the exact same problem and have copied everything to a tee , and yes everything is identical with the same results. I have looked at other forums but none covered the cc3d. the only difference, I have the D8R-XP. I found one forum that discussed the install with the smartypants board with no problems. I don’t have smartypants. Anybody have suggestions for Togapiggy ad myself?


#9

I actually found the problem.
First off, the wires coming off my cc3d, I needed to release the signal wire from the connector and move it all the way to the end into pin #8.

Now go to LibrePilot, configuration tab, hardware, and make sure the cc3d is set to PPM_PIN8+OneShot

Now check the Output tab and set 1 (1-3) & 2(4) to PWMSync. 3(5,7-8) & 4(6,9-10) will be PWM.

Once all that was set I had no problems!

I hope this gets you up and running.

Curious…are you also setting up a Eachine 250 racer?
If so I highly recommend doing the VTX relocation mod. I put mine on the bottom plate in the back and moved the battery to the top plate. It’s not so ass heavy now and the poor TX antenna doesn’t take the full brunt of roll over crashes.

Happy flying


#10

Great, I’ll be doing the same shortly, that is one way I did not configure setup. I’m running a 300 inverted quad. My second, which is why I’m switching over to djt-d8rpw. Lost the last one without telemetry,plus my 650mm alien needs it too, just in case but I usually fly it LOS. I’ll let you know my results I also have the regular th9x receiver


#11

Still no luck. What are your settings for the transmitter page. I’ve got the other settings correct which makes alot of sense now that it is set, but I’m just not seeing where the problem is now .Thanks Togapiggy for your insight, maybe you’ve set up transmitter page different.thanks for your help.


#12

I , today ordered the smartypants mini board. Its so you can load firmware onto transmitter without all the extras and extra cost of the big board. Less than $20.00 .Can’t complain about the price for the ability to upgrade firmware…


#13

Settings for my Turnigy 9xr
On page 5
CH1 100 RUD
CH2 100 ELE
CH3 100 THR
CH4 100 AIL
CH5 100 sIDxID0 <-(that’s just for flight modes)