Problems with CC3D LibrePilot Flysky FS-i6s Transmitter Setup 😧

flysky

#1

All, here is a YouTube video that describes my problem exactly, can’t get past the pitch segment.

Tried most of the suggestions down below the video but no luck. Please help if you can, spent way too many hours trying to resolve. Build at stand still.

Thanks in advance
Jim


#2

First, on the flysky radio itself there is a monitor screen that lets you see bars moving corresponding to how you move the sticks. On that screen you can make sure everything is working at it should. I dont remember right now which menu screen is under but its somewhere there. Also the second thing is to make sure you dont have any mixing going on on your radio. We have guide on how to setup the flysky I6 radio here that might help getting it all sorted.

Last issue is to double check your connections between the receiver and your Cc3D board.


#3

Thanks for your help.

I checked the monitor screen numerous times and all the sticks work showing the bars moving, all is well there. The transmitter works well with a quad simulator.

Check mixing and it is off. Watched the video, all is good.

As far as the connections, I have tried many combinations to no avail.

I am stumped. Do you think the FC board is bad? Should I try an older revision of Openpilot, could that help?

Jim


#4

Plot Thickens. I tested the radio and receiver with a servo from one of my old gliders. What I found was channel 1 is ailerons, Channel 2 is both throttle and elevator, Channel 3 is throttle and elevator, and channel 4 is rudder. Channel 2 and 3 are acting like they are mixed. So is my receiver bad. I have checked the Flysky i6s radio for any mixing and the mixing is off. Any ideas? Thanks.


#5

That is strange indeed, but does look like there is definitely some mixing going on… when you selected a model on your radio did you select helicopter or airplabe mode, as you must use airplane mode for multirotors