TBS Unify race HV losing video fixed


#1

Hello i have problem with my unify race hv. Im getting maybe 20m sort of range on 200mw. yesterday was prfect and now i can barely fly. Any idea what could be wrong ?


#2

It looks to me that your either in PIT mode or you have a dead antenna.

When you close to you your feed is good and clear so it looks like your on the right channel.
But soon as you move away it breaks up.

What antenna you running on your frame and goggles?


#3

On both i have pagoda antenna. That was first what i done. I swap antenna on vtx for new one. On goggles two pagodas. On unify i have solid blue and red led after arming.


#4

I think you have activated pitmode

Unify Pro HV RACE using push-button:
Activate PitMode​: push-button needs to be hold while the Unify Pro RACE is powered up. This will
permanently enable PitMode even during power cycle. Powering up the Unify pro RACE in PitMode
is indicated by a solid red LED only.
Activate VTX to fly​: wait until it’s up and running and press the push-button for 8 seconds. The
Unify Pro RACE will set the output power according to the power settings and is ready to fly.
Deactivate PitMode: ​push-button needs to be hold while the Unify Pro RACE is powered up. This
will permanently disable PitMode even during power cycle. The LED will show blue in case the
Unify Pro RACE is locked and blue and red in case it’s unlocked


#5

I was thinking about it but in pit mode " Powering up the Unify pro RACE in PitMode
is indicated by a solid red LED only" and i have blue and red. Is there any way to check that in smart audio ? Will try again when i will back home.


#6

Ok problem fixed. Inside part of sma connector in pigtail, there where signal bolts going inside connector was push back. I move it forward and its work like a charm


#7

Nice.

Glad is was an easy fix and your back up in the air


#8

Hi I had something like your problem found out where the antenna goes under the black shrink tubing it was broken etc craked peel back have a look make sure the other end is in properly to as that can come loose. Hope this helps


#9

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.