Tarot 2D gimbal and Pixhawk - Tilt control


#1

Hi everyone,

Thanks Unmannedtech for creating this community.
Living in Europe, I’m glad to discover your shop!

I’ve tried my luck asking this question on other forums with no luck.
I’ve seen really interesting interactions here so I’m thinking DroneTrest may be the place I finally get help :slight_smile:

Here is the issue:
I can’t get to control my tarot gimbal tilt from my RC through the Pixhawk.
I think the Pixhawk is running the latest apm version (I updated it a month ago).

I’ve found two different wiring instructions.

None would work for me.
With the 3 wires option, the gimbal turns and locks facing up/left.
With the 2 wires option, the gimbal behaves like it’s working independently (i.e. stabilizes nicely, keeping the camera straight, but now way to command it).

I checked in APM PLANNER, RC calibration, the knob (pot) I want to use seems properly mixed to channel 6 and I can see the gauge moving on the calibration page.
So it seems that it is not something on the RC side or the Rx.
Btw, I use a turnigy 9x flashed with the er9x firmware. The receiver is a FrSky D8r-II plus flashed with the XP firmware to get PPM.

I also followed the wiki instructions to configure the gimbal in the mission planner.

I uploaded the 3dr settings to the gimbal with the tarot flashing software.
And the gimbal is running the 1.4 firmware.

So please, can anyone help me find where I’m messing up?
And as a starting point: is it a 2 or 3 cables wiring needed to the pixhawk?

Many thanks for your help!!!
Wishing a nice Saturday to everyone :sunny:


#2

Welcome to the forums :thumbsup:

My suggestion would be to simply connect the pitch control from the tarrot 2D gimbal directly to your receiver and bypass pixhawk alltogether, then you dont need to change any settings on your pixhawk. But this will only work if you are using a regular PWM receiver.

If using a PPM receiver then you will need to change the settings within the mission planner. You will need to enable ptilt control but make sure to disable the Stabilise Tilt option. If this is enabled the tarrot 2D gimbal will get confused with the command signals coming from the pixhawk. You will then need to connect the tarrot 2D gimbal to the correct output port on your pixhawk board.

If you find that the gimbal is moving weirdly then make sure its connected to the correct channel and your switches are set correctly on your transmitter. You should find that the roll axis should be correct, but the pitch is weird if something is set wrong.

Otherwise I would suggest you follow the instructions from the arducopter wiki - http://copter.ardupilot.com/wiki/common-tarot-gimbal/

Hope that helps


#3

Thanks for your reply unmannedtech.

If nothing works, I’ll try to connect it directly to the receiver.
Just not sure how to do with the D8R II plus flashed with the D8R XP firmware to get PPM.
But I’ll figure out whether its possible or not…

I’m sure I got it wrong somewhere.

Thanks again,
Best,
Mathieu


#4

How did you get on with this @mterzian?

I’m running almost the same set up and seem to be hitting the same problem.
However instead of flashing D8R II, I’m using a ppm encoder board (you can find them really cheap on ebay) so I’ve just unplugged channel 6 from the encoder and stuck the tilt wire directly into the receiver. This works well but I’d still like to get it running through the pixhawk so I can experiment with autonomous missions.

Jon


#5

Hi Jon,
Sorry it took me some time to reply,

For some reason, I finally got it to work.
I rewired everything, reinstalled the tarot firmware (gimbal + motors), tweaked the gimbal configuration in APM mission planner according to the wiki, and… it’s now working.
Maybe I was so impatient to have the gimbal tilt command work that I didn’t turn the knob enough.
The gimbal starts to tilt after I give the knob a 1/4 - 1/3 turn.

ALSO make sure you calibrated the gimbal sensor in the Tarot software (back of the camera mount laid on a flat surface, camera facing up) and see if it works.
I think this is what unlocked everything for me.

Good luck!
Mathieu


#6

Thanks Mathieu, I’ll give that ago and let you know how I get on.
Jon


#7

Hi All,

I am having the same issues that I am not able to operate my Tarot 2-D gimbal through RC.

Here are more details about my systems and things I’ve tried so far.

  1. Pixhawk with Arducopter V3.3.3,

  2. S900 airframe

  3. Followed all the instructions given here , http://ardupilot.org/copter/docs/common-tarot-gimbal.html

  4. Tarot 2-D gimbal with Gopro 4, latest firmware flashed

  5. Output rail powered via separate BEC (although not necessary since Gimbal is powered on it’s own)

Gimbal operations; It maintains preset attitude (GoPro camera orientation) pretty well, flight tested.

My goal;

I am trying to get the manual control of camera via RC working but no luck so far,

I have tested the toggle option via Mission planner and Gimbal moves fine but when I try to operate via Transmitter the gimbal doesn’t work.

What am I doing wrong ? any suggestions ?