Syma X8 Quad. Transmitter problem?


#1

Hello all. I was given a Syma X8 which wouldn’t fly. I tried to fly it without success. It appeared that one of the props was not revolving.

I had assumed that one of the motors had failed. I used the mm to test continuity and all wiring seemed OK. I then tested the suspect motor in another motor connector. It was fine. Using the transmitter (obviously) I tested all four motors in all 4 different motor connectors, but one at a time, individually. They all worked fine in response to the transmitter. I then connected all four motors to their prop connectors (being very careful to make sure that A’s and B’s were in the right place), but leaving the quad top off so I could observe the shafts.

Turned on the transmitter, then the quad. On this quad you arm the motors by turning the left stick to the bottom position, then the top, then bottom again, and then going upwards again, the motors arm. And so they did. All but one. I moved the stick very slightly upwards more. The still motor started. Moved the stick to centre. All 4 motors going. Moved the sick north more, motors accelerated and then two of them stopped.
I repeated this 10 times with the same result.

I am assuming this is a transmitter fault. What do you think? Some photos attached.Syma 1

Syma 2

Syma 3


#2

Hey cantlyfly,

Since this is a RTF Drone and not meant to repair something is quite difficult.
However:
Which Motors stop and were the stopping Motors every time the same ones?
Please tell us the Motor Numbers.
Motor Numbers:
11-MotorsDirectionAndNumbers

(Edit: You only need to try this if you fly in Acro/Rate Mode:

If your Drone is able to fly, try to do the same “experiment” while your Drone flies.
_My Idea is that your Drone (because it is sitting on the bench and cant move itself) is thinking _
that i cant move itself due to Wind (or something else).
Therefore it keeps accelerating the Motors that are needed to fly your maneuver until the not needed Motors even stop spinning.)

To be honest:
Since your Drone is not meant to be understoud by other Persons exept the ones who build it and its not meant to repair it im not very confident that there is a good solution :confused: :disappointed_relieved:

Luca :slight_smile:


#3

Thanks Luca.

The motors appear to stop erratically with no particular pattern. Why I thought it might be a transmitter problem was that even if all 4 motors are firing in the mid (hover?) position, at least 1 if not 2, stop, as you move the left stick upwards. Because of this, it’s just as well I cant get the quad off the ground, as it would obviously fall out of the sky as the motors stopped.

I believe you are correct in that it may not repairable as a cheap drone, but it seems quite a popular model. There are a lot of them for sale on Ebay.


#4

Sadly the popularity doesnt mean how good you can repair it.
To me it sounds like a Problem that cannot be solved wiht your setup.

Please upload a Video that shows your Problem.
Maybe that will help us or show a way on what may be the Probelm exactly :confused:

Luca :slight_smile:


#5

My only suggestions would be to buy a new flight controller (if you can find the exact same one). But with these quads they are not designed to be repaired/modified so figuring this all out on your own can be a big pain. And even if you do get a new FC, there is no guarantee that is what is causing the problem, as it could also be your radio.

My only other suggestion if it is still under warranty, or you purchased with paypal then you should have 180 days to get the shop to repair/replace/refund the product if this fault was not caused by you crashing/damaging it yourself.


#6

Please upload a Video that shows your Problem.

I will do so. I will be interested in opinions. Will upload in the next couple of days.


#7

Thanks Alex.

My only other suggestion if it is still under warranty

A friend gave me the quad as he had given it up as a lost cause. I believe the warranty is long gone. So, with nothing to lose, I thought I would try with my next to zero knowledge, to get it going.

After having done a little studying and watched a few youtube slots for electronics beginners, I wonder if you could clear something up. The leads to the 4 motors terminate in aESC 1 small square insert with a + and - that slots into the connector that the motor connectors marry up to. See photos. Are these the electronic speed controllers?ESC 2


#8

I don’t think they are speed controllers.
ESCs take a DC input and signal wire and convert that into 3 phase AC for the motors.

I only see two wires which to me indicates a DC motor (also looks geared)
so all the control is probably on the main board.


#9

Thanks DoomedFPV.

I am very much in the learner stage and appreciate all replies. What function do you think these small square inserts serve?

I know the quad in question is a cheap, unsophisticated model but I suppose you can always learn something. From the photograph of the main board and with my extremely limited knowledge, I think I can identify: 3 capacitors, a couple of transistors, several tiny ic’s, and what I believe are 2 heat sinks. If this is correct, will the esp’s to the 4 motors be somehow incorporated in the ic’s?Circuit board compressedConnection compressed


#10

Hey cantly,

I think there may be an Problem with the Software or the intenal electronics.
If this is the case, there is no way you can repair this.
I found following “Trick” that had a guy with a similar Problem.
many Persons sad that you need to turn off your TX hold the Trim Button up (right side of the power Button)
and than turn it on.
I found multiple comments that sad this will work.
Hope it will fix your Problem.

Luca :slight_smile:


#11

Thanks again Luca,

I’ll give it a go and report back

cantfly


#12

A quad manualja meg van? Ha nincs meg, akkor letölthető a Syma.com oldalról.
Javaslom a manuál tanulmányozását, mert lehet az adó van elprogramozva.
Kefés motorok vannak benne, azért csak kettő vezeték csatlakozik hozzá!
Üdv. Jimmi


#13

@Jimmi46

Can we get that in English please.


#14

Does the quad manual have it? If not, you can download it from Syma.com.
I suggest the manual study because the transmitter can be programmed.
There are brushed motors, so only two wires are connected to it!
Hi. Jimmi


#15

Thanks Jimmi46

I will download and study manual but I am beginning to give up on this quad.


#16

Glad you said that, DoomedFPV,

Hungarian is one language I wouldn’t want to tackle!


#17

Luca,

I tried it but it made no difference unfortunately.

I also tried to reset the quad and transmitter following the instructions in the manual. If anything, that seemed to make things worse.

What I found was happening before I tried resetting was that, the 4 motors would come on and accelerate if I pushed the throttle stick upwards at an angle of 13.05 (5 past one) but even then and at full throttle, the quad would not ascend even an inch. If I pushed the stick directly upwards, only 3 motors would come on. Since I tried resetting (which is merely moving both sticks to the SSE position), the situation is even worse, the motors stop and wont come on again, unless I turn quad and tx off and then on again.

Another problem is the camera. I scanned and installed the app for the camera from the Syma site, on to my phone. Basically you then turn the camera on and then open Wi Fi connections on the phone, and wait to see if FPV appears. It did but kept disconnecting and reconnecting. When it show a steady connection it also said “no internet”. Anyway once the FPV says connected, you are supposed to then open the Syma app, click on camera and then see footage on your phone screen. This isn’t happening. The Syma app just keeps saying “Camera not connected”.

You can buy a new TX and camera for this quad dirt cheap on Bangood. But I am wondering if that will solve the problems?