Strange Voltage Fluctuation


#1

Hello,

I’m making my first drone, and I’ve run into a few issues, but the problem right now is quite confusing, and I was wondering if anyone had any input.

To put this all out there: I’m using an SP Racing F3 flight controller and a RadioLink T8FB controller. I have both Cleanflight and Betaflight, but I favor the former. My ESCs are HAKRC BLHeli-32, and I’m using DSHOT1200.

I’ve been using SBUS for this project so far, and motors #1 and #3 work fine, but #2 seems to get too much voltage too quick, and #4 doesn’t start spinning until about 3/4 of the stick is up and only gets half power at full throttle (shown by the motors tab in Betaflight). I switched to PPM to see if it was just SBUS that was the problem, but then it was #2 and #4 working fine and #1 getting too much and #3 getting too little. To clarify, all of this is seen by using my controller (a RadioLink T8FB) with the receiver in the motors tab, because using the master controls in Betaflight, all the motors seem to run at the desired rate. I tried switching the cable I was using to attach the UART port to the receiver, but it ran the same. I can only assume there is a problem with the radio signal (because of how it worked in Betaflight), but I don’t see how that’s possible. Any thoughts?


#2

Im not too familiar with your Radio but try to delete the current settings for the model and rebind everything.
-I dont think there is a Cabel issue because if the Problem accurs differently by only changing the Protocol it is not likely to be a cabel issue.
-Try to use Betaflight instead of Cleanflight since it is no longer supported. (May be wrong about that but i heared it few months ago)
-Please provide screenshots or cli recordings of your settings so we can have a look. Maybe there is just a little mistake or something. You never know :wink: