Splicing damaged USB charger to battery connector


#1

The battery (3.7v), of course, has 2 wires, red and black.

The charger also has 2, white and green. I understand these are data wires with white as positive and green as negative. Will it be safe to splice a connector to the charger? i.e: white to red and black to green?


#2

Hey cantfly,
Since these wires are meant for Datatransfer i think that they wont work…
I didnt find any pictures but this is how a usb looks like: (not exactly but you get the point)


(ROSA = WHITE)
I think that you would have to take the power wires and not the data wires…
The Datawires probably wont offer a constant energy flow like the power wires…

To your Question:
It will probably safe but i think it wont work.

I hope you understood my chain of thought :smiley:

Luca :slight_smile:


#3

IMG_2726

Hi Luca,

I took a chance and tried it anyway. You were bang on the money. It didn’t. I charged for an hour and then not a peep out of the battery. (But I suppose there is the possibility that it might be a naffed battery?
What I am a bit perplexed about is: the charger lead only had the 2 wires i.e: green and white. These obviously connected to the red and black wires of the battery. I cut off the damaged connector and spliced the 2 lots of wires together as I said, to no avail. How then, did the undamaged charger charge the battery? Sorry if this is simplistic. I am still learning.


#4

May there be a Problem with the Cable itself or the Charger or the battery ?


#5

Do you have a multimeter to check if you are getting any power from the white/green wires from your USB charger?


#6

Great Idea :smile:
Didnt thought about that :smile:


#7

No, but I am getting one.

This thread is kind of a follow up to the “battery for toy drone” thread. The batteries with 1.25JST terminals appear impossible to get, so following your (and others) kind advice, I solved the problem by getting batteries with 2.0 JST terminals and making up a fly lead with a 1.25 JST. This charged up no problem, but now, as soon as I insert these batteries, (same spec as original battery: 3.7v 150mAh) and turn on the drone power switch the props immediately start at what appears to be full throttle. I have the R/C switched on before I turn on the drone switch, but there seems to be no sync now between the two. The R/C itself has new batteries and worked absolutely fine with the old battery. I wondered what I can try to get over this?


#8

I checked the drone instructions and the original battery spec was:

3.7v 200 mAh

The new battery spec is:

3.7v 150 mAh

Will this make a difference to the R/C synching with the drone?