PX4IO not found - 3.3v reg?

pixhawk

#1

I cannot get any of the IO parts of my Pixhack (RC, servos) to work, yet mavlink and general control works. Looking at bootlog, I see:

ERROR: PX4IO update failed
ERROR: PX4IO not found

Having looked online, there are a few suggestions this could be due to old firmware on the board (unlikely, board is new) and that holding safety switch whilst booting should fix the problem; it doesn’t. Also a few forums suggest that the 3.3v regulator could be blown. This is possible, as I made a couple of mistakes early on regarding power supply.

Is there a schematic/guide/somewhere I can find out where the 3.3v regulator is, how to test it, and how to fix it? Most forums regard the Pixhawk, so slightly different board design? I have a multimeter/scope handy.

Thank you!


#2

Hi, have you tried to format your SD card as something that is a general solution to most problems surprisingly :P. And also try to load the latest firmware as many pixhawk boards dont actually have the latest firmware on them

Also do you have anything else connected to your pixhawk during power up? Sometimes some peripherals including your reciever could draw too much current and either cause the update to for or worse :-(. My suggestion would be to only connect the buzzer and safety switch and after formatting the SD card try a firmware update again to see if that works.

Also you might want to power your pixhawk via a battery (via the power module) in case your USB port is not providing enough power.


#3

I think I’ve already tried pretty much everything you suggested.

I discovered the SD was corrupted yesterday, it was only after reformatting that I was able to get the logfile and the PX4IO error.

Since then I have reformatted the card again and loaded the latest firmware, with both Mission Planner and QGC.

I have tried having nothing but buzzer connected powered from USB, no luck. I have also tried with only buzzer and the ESC (no servos) attached as described below.


#4

Also, the Pixhack won’t power when attached to just the power module. The PM output is 5v, but the Pixhack stays off. It is only by attaching the ESC (which is powered by the battery) that the Pixhack turns on, presumably being powered through the ESC. Does this indicate a power issue in the module or on the board?


#5

It does seem like your board might be damaged so best to contact the shop you ordered from as they should be able to repair/replace it for you. Did you order yours from us?

As for PM, have you measured the output voltage?/ in general is quite uncommon for power module to have a fault unless you plugged it only a battery above the supported voltage range.


#6

Yes, I ordered mine from you. I shall ring up today to try and sort it on the number on your website. May be tricky as it was purchased via a third party company ( I am doing a project in conjunction with them).

Yeah I’ve measured the output voltage of the board and it was ~5v, hence why I suspect a board issue.


#7

Sure, its probably best to send us an email with your order number so we can create a return for you and get the problem fixed.