Issues Powering Pixhack


#1

I’m having issues powering my Pixhack board.

Previously, it was working fine via battery (5100mAh 10C 3S) and USB. Now, it seems to only work via USB.

When I connect with battery, nothing happens.

When I connect with USB it boots fine. If I then plug in the battery, QGroundControl gives me fluctuating readings of battery voltage (2.3 - 3.5V) for about 10/20 seconds, before losing connection. The power to all peripherals such as telemetry unit is sustained, until I remove the USB when all power is lost.

Using a multimeter, the battery voltage is 12V, the voltage from the Power Module is 5.3V (both ends of the cables). I have no ESC/servos attached.

Why is there this erroneous battery voltage reading, and why doesn’t it power the board?

I have tried reflashing the firmware and resetting all parameters to default.

Edit: I am now getting battery readings on QGroundControl with no battery connected!? This is stable at 2.13V rather than fluctuating.


#2

That does sound strange. However one thing that we have found works is to install a different type of firmware onto your pixhack (so if you are using arducopter, install arduplane) and then go back to arducopter, as this will reset the EEPROM settings. I have bashed my head against the wall for a few hours once with a pixhawk board not working correctly, but after doing a factory reset then it worked perfectly. There are hundreds of parameters you can set on the board and sometimes something is not set right which can cause all sorts of weird behavior. So that is my suggestion that you should first try.

Also by the sounds of it your power module is working just fine if its outputting a constant 5.3V to your pixhack.

You say that when you connect via battery, do you not get any lights on your pixhack? If so you should double check the connections and that you have connected it into the correct port on your pixhack. If you are not sure please send me a photo showing your setup and I can try to help.

Lastly once that is done have you calibrated your power module settings via mission planner? As that is usually the cause for strange voltage and current readings in mission planner.