Pixhawk Power Module Voltage Drops

pixhawk

#1

Hi,

I purchased PIxhawk 2.1 and it came with its own Power Module (power brick). I assembled and configured a quadcopter. When I connected the battery that is fully charged everything works fine. However, if battery is not fully charged (voltage slightly off) I get the Low Battery beeping.

It narrowed down the problem to the Power Module. Apparently, it reads voltage about 2 V below of the actual battery voltage. I even disconnected all components from Pixhawk and just left connected a buzzer, a safety switch and the battery through PM, but the problem with the low battery is not going away.

I’m using QGroundControl (on Mac). When I connect a USB cable and the battery, the PM reads 10.55V in QGC, for the fully charged 3S battery, which actually has 12.53V as tested with the voltmeter. At this voltage, I get a Low Battery warning from QGC speaking, but no buzzer.

When the actual battery voltage drops a bit to 12.45V, I get a buzzer beeping and QGC shows only 13% of the battery at 10.46V.

So, Pixhawk’s Power Module seems to lose about 2 V from the actual battery’s voltage. Keep in mind that there is really no load on the system and ESCs are not even connected - everything is at rest. Did I get a faulty PM with my purchase or did I do something wrong with PM’s calibration?

I searched google for straight 2 days but can’t find the answer. I would understand if PM loses some 0.2/0.3 V, but not the full 2V. Something seems oddly wrong here.

I’m using 3S 5000mAh 52C battery.
Pixhawk is fully configured with QGC and has the following parameters:
Number of cells: 3S
Full Voltage: 4.05V
Empty Voltage: 3.40V
Voltage divider: 10.17793941
Amps per volt: 15.39103031

Here are snapshots from QGC:

Please help!


#2

I was able to resolve this on my own. After I carefully read the instructions I realized that in order to perform the battery calibration the actual battery must be plugged in. My rookie mistake! Once I performed the calibration with plugged in battery the number jumped to 12.23234653, which made QGC to correctly displayed battery at 100%.


#3

Sorry I did not get to this before as could of saved you some time, but happy that you figured it all out :slight_smile: Its all part of the ‘fun’ when setting up a new autopilot system!