RC issues with Pixhack


#1

I have setup (mostly) a Pixhack, but I cannot get any form of RC detection. Have spent quite a few days trying to fix this, and I both hope and am worried I have missed something simple.

The Pixhack is calibrated for everything else (compass/gyro etc), using QGroundControl. I have tried APM Planner 2.0 and Mission Planner, but have the same issue. When attempting to calibrate the radio, I get an error message “0 RC channels detected”. Mavlink inspector shows no RC packets. I have reflashed multiple times with differing firmwares to try and eliminate any firmware issues, and have tried powering via both battery and USB.

After flashing, I set airframe, calibrate sensors, and map RC channels 1-4 correctly, and 5 for mode switch. I go to RC calibration, and get the error above “0 rc channels detected”.

The RC appears to all be working correctly. If I connect the output from the RX701 directly into the ESC, I can control individual motors. With the RX701 connected to the PPM encoder (v2 from UnmannedTech), the PPM encoder light flashing rate changes appropriately when I turn on RC transmitter.

I will be getting access to a multimeter soon so could test the PPM input/output? What should I be looking for? (could get access to an oscilloscope if really needed).


#2

Not sure if you have checked, but is the ppm encoder providing power to your receiver?


#3

yes - I asked here about that earlier, and you (correctly) pointed me towards the jumper which needed soldering. After that the rx correctly receives power.