Pixracer on Flying Wing

pixracer
flyingwings
qgroundconrol
px4

#1

Hi,
I am setting up a PixRacer V1 on a Threer flying wing with Qground control and PX4 stack firmware.
At power up one servo moves hard to end point and neither servos or motor respond to stick controls
I’ve checked and double checked my wiring, servos on Ch.1,2 and ESC on Ch. 4, tried both Generic and WingWing airframe configurations.
Also cannot get my (known good) GPS puck recognised, does anybody know what baudrate the PixRacer UART3 port is on?
Maybe these problems are connected, maybe I have a duff board. :sob:
I’m contemplating starting from scratch with Ardupilot and Mission Planner, but if anybody reading this has any experience with Pixracer, PX4 and wings I’d appreciate hearing from you
Thanks
Steve :slight_smile:


#2

I have not had much practice recently with wings and pixhawk, and I dont know the default UART3 baud rate (should be 115200), but you can set the GPS protocol to be auto, and it should detect it automatically. Otherwise you can change the buad rate manually via the full parameters list. One thing to double check though is the connection so TX goes to RX on the board, and vice versa…

As for the servos, what are your arm switch settings, as maybe it is disabling servo outputs until you arm. Otherwise you can try to try servo pass-through just to verify the outputs are working on your pixhawk.

However, in my experience when you get stuck like this, its usually best to just to a factory reset and start again, as from time to time a strange setting is saved on the EEPROM and given the vast amount of parameters you can set, it will be faster to start again rather than going through them all one by one.

If you still get stuck, let me know and I can look into this abit more for you


#3

Hi Alex @unmannedtech

Having tried a few options I’m fairly sure there is a problem with the unit, so I’ve swapped it out for a Omnibus 3 running iNav.
i’ll come back to it another week/month :grinning: or maybe ditch it and invest in the Pixhawk Mini.

Thanks
Steve :confused:


#4