Pixhawk Servos not responding (2.4.8 Plane)

pixhawk

#1

Howdy,

This board is driving me nuts. I can’t get a servo to work with it at all!

Things I’ve tried so far:

  1. Swapped the ESC for another (both were known working)
  2. Swapped the servos for different ones, all work fine on the servo tester
  3. I double checked that I have the servo wires up the right way
  4. The RC inputs are right, I’ve done that numerous times now and every works fine on the receiver screen in mission planner
  5. I’ve swapped receivers from a D4R-II to a X8R using SBUS
  6. I can arm the board (disabled the hardware switch option)
  7. And yes I get a GPS 3D fix
    8… Sworn at it loads :slight_smile:

And still nothing!!

Any ideas or suggestions?

Matt

Image links below:


#2

Hi
I use Michael on multimotor.
I see you have the setup seems correct.
However I notice USB cable.
The USB cable cannot give enough power to power servos.
In MP it will arm etc but will not be able to power servos.you have to power up the system by battery and then arm with Tx. I use X8r Rx with taranis. Please try powering system with battery. Stick with sbus


#3

Howdy,

It turned out I didn’t have the buzzer or arm switch in the kit I bought, hence the issues. They arrived, plugged in and happy days!

Matt

Also I worked out how to bypass them in the settings, a video is here and then she would arm & had servo movement!