Pixhawk instability

pixhawk
multirotor

#1

Hi

I recently bought a Pixhawk. I have installed and flashed it, I can not get it stay level. It always flips. I have checked esc calibration and motor rotation and I have made sure I am using the right props on the right motors.

These are the basic specs for my setup:

250 frame
Flight controller - Pixhawk
ESC - afro 12A ------------- running BLHeli, PWM mode on
Motors - DYS BE1806 2300KV
Props - 6*4 (a little large I know)

Any help would be much appreciated.


#2

Have you also checked your esc/motors are connected to the correct outputs on pixhawk?

I am also assuming you have completed the radio calibration and made sure there is no mixing set on your R/C radio?

Lastly, if your pixhawk is connected via USB and you tilt your quad left/right does the HUD react how it should?

Otherwise this post might help you


#3

hi Tropnevad

So I read the other article before posting and I made sure I was connected to the right outputs (I was not, but after correcting I am still having these problems) The hud does react correctly (I am using telemetry but it also reacts properly on usb power as well) and the ESCs have all been calibrated ( the calibration was a little odd though, I had to raise and lower the throttle twice, not once as it should)

I don’t know about the mixing, however should that really effect the stabilise mode when I am only inputing throttle to take off?

The motors seems to react very out off time and one cuts out at certain angles, I think it is the escs which are causing this… should PWM mode be on are off and should I try using SimonK instead of BLHeli (if so where can I find a SimonK suite to flash the escs)

Thanks for all the help,
Harry


#4

Yes that is very important, if there is mixing on your radio (often the case with R/C helicopter radios) when you increase throttle it will mix in a bit of yaw to compensate the spinnng effect of the main rotors, but since pixhawk takes care of all the mixing internally sending mixing commands from the R/C radio will cause problems.

When you arm pixhawk do they all spin as the same speed and start spinning at the same time? It is normal for motors to spin at different speeds when you tilt the quad as they are reacting to keep quadcopter level, so i you tilt quad forward by hand, rear motors will slow down and front ones will speed up to try compensate for the motion and return your arducopter to level flight.

Last thing to check, do your ESC’s use switch mode BEC’s? If so you will need to remove the red wire from all but 1 ESC servo connector as these can cause interference with one another.


#5

My radio is a Frsky taranis and I am not aware that I have any mixing currently, I did not program any when I set up the profile. The motors tend to act in response to tilting correctly, however suddenly they become disorientated and stop reacting as they should, once tends to cut out more than the others. They do spin up at the same time. How ever Afro 12A esc do all have a 0.5A linear BEC. This might be it!! I will disconnect all but one of the power wires and get back to you,

Thanks for all the help


#6

I have removed all but one of the red wires from my esc servo connectors, however I am still encountering the same problems, the motors seems to stutter, it only happens on certain motors, and it happens when they should be speeding up to counter for some roll or elevation, not when they should be slowing down, I will try some different esc settings and post a video. Could the BL Heli software have something to do with this?

And how would I download the log so that some one more experienced can try and decipher a problem?


#7

After you mentioned that your ESC’s have linear BEC I was not sure if that would solve the issue as its the switch mode BEC’s that can cause inteference with one another. You said you are using Afro ESC’s and I know of a buch of people having sync issues with these ESC’s which is what I think the issue is. Are you using SimonK or BLheli firmware on your ESC?

In terms of checking if it is a sync issue you can look at the logs and inspect the RC_out commans send from your pixhawk to the ESC. If the RC out is all over the place then the problem is likely that pixhawk has some sensor issues and is sending strange commands to the motors. Otherwise if the RC_out is smooth according to your throttle inputs then the issue is likely something with the ESC. If you dont know how to look at the logs check out the quick guide on how to analyse Pixhawk log files.

Let me know how you get on, but I feel that using latest BLheli firmware should fix the issue as that is what other users report. I myself dont have loads experience with AFRO ESC’s as we dont sell them yet. I have only used some with a miniquad powered by a flip32+ board but did not have any issues.


#8

Here are some pictures of the logs, I don’t know if these look particularly erratic?





#9

Just to clarify I am using the latest version BLHeli on Afro 12A escs ,should I try using SimonK instead?


#10

Thanks for the logs, its abit hard to tel from those images. THe best way to test this would be to position your quadcopter level on the ground with the props reversed, or your quad bolted to the ground, and smoothly increase the throttle up and down, and then rapidly increase throttle up and down. If pixhawk is working as it should you should see the same RC_out commands sent to all 4 ESC’s, but the best way to look would be to create a graph of all 4 RCoutputs superimposed on the same graph so its easier to compare.

Another thing to check for a problem is to compare the ROLL and ROLL IN values on the ATT lines for the dataflash. In the example below you can see that the aircrafts actual roll follows the desired roll until the end where there was a problem. If you compare these for one of your flights you should see something similar.


#11

Thanks I will try this and get back to you,


Very unstable Pixhawk
#12

Stupid question but last time I went through all this it turned out one of the screws holding the motor to the frame was slightly too long, ar you getting any unusual levels of heat in the motors that stutter?


#13

Good point that I did not consider