3DR Quadcopter single motor power loss


#1

I’ve just completed a build & attempted test flight of a 3DR quadcopter kit, with Pixhawk controller & GPS, and Futaba S-Bus R\C receiver.

The machine appears correctly set-up and arms properly etc
I’ve been flying model Helis for about 20 years, so my basic control skills are reasonably good.
.
After a gentle run-up of the motors it will take-off into a low hover and then sit fairly stable for around 30-60 seconds. Pitch and yaw control seems OK at first, but then after a random (<60 seconds) a single motor slows-down suddenly causing a near flip\crash. I’m not sure if there’s also a sudden power increase in the “opposite” motor.

Experimentation has shown that its usually either the front left, or right rear motor that fluctuates, and if the machine is “tethered” the failing motor speeds up again after a very short interval.

I’ve faffed around with checking logs etc, but there doesn’t seem to be any obvious cause (vibration, seems OK, for example) and the GPS\compass\ attitude all seems OK until the suden near-fliop.

In a word: “Help!”

TIA


#2

Sorry to hear about that, from your post I am assuming that this is a rather consistent problem with your arducopter that is happening, is that correct? :helicopter: > :clock2: > :boom:

As for the problem, does this only occur when you throttle up beyond a certain value, or does it seem to be time based? If its only when you throttle up beyond a certain value then it could be some mixing going on from your R/C radio.

I am assuming you have completed the basic ESC calibration steps, and also radio calibration via mission planner?


#3

Hi

Thanks for the quick reply.

Yes, 100% consistent, unfortunately!

As far as I can tell, it seems to happen after a time, rather than be related to a specific throttle opening.

With the drone tethered I can increse the throttle past “hover” without any immediate glitch. It appears there’s no obvious correalation between throttle and the problem. Then, after an inconsistent, but quite short period, the motor glitches.

There’;s definitely NO mixing in my radio - set to Basic Aeroplane as per setup instructions. I did have to reverse the throttle channel.
I’ve calibrated the ESC’s as per the online "all at once " instructions, and everything seems hunky-dory reponding exactly as it is supposed to.

I’m also running in “stabilize” (set all modes to this, to prevent finger trouble!).

I haven’t yet configured additional switch channels (except 5 which is part of Calibration).

After my most recent session (yesterday) I did notice my Lipo was at a low state of charge - could this be triggering some kind of FAILSAFE operating on only 1 esc?

Seems unlikely, but…

Final question. I’ve configured the 3dr Quad kit as an “X” configuration, though its not strictly a symmetical X shape (the front & rear arms being in perfect alignment) . Should it be configured via Mission Planner as a “Y” .

I’ll have another go this evening and double-check everything and use a fully-charged LiPo.


#4

It could definitely be related to your low lipo voltage where once ESC is detecting a low battery and cutting out, however most multicopter ESC’s now days have this feature disabled.

The other thing it could be is related to an ESC/motor sync issue, the video below shows the problem and how to test for it

If that is your problem let me know and I can try to help you troubleshoot it further.


#5

Hi

I’ve now got a fully charged 5000 Mah 3S Lipo connected to the system.

OK so I watched thevideo, and a couple of others, and I’m pretty sure I’m suffering from the “out of sync” syndrome.

I tried to find the “motorsync” test in Mission Planner (via the console) but this appears to have been deprecated for my Pixhawk firmware version (latest download).

What is happening is that under fast speed increase one or more motors fails to speed-up, and at a constant (high) speed one or more will fluctuate.

I haven’t tested this extensively yet (work in progress) , but these are the broad symptoms I’m suffering.

I’ll do some more research, but any further help you can provide will be much appreciated!

Thanks


#6

Ok that does definitely sound like a motorsync issue. First thing to check, have you made sure to connect the ground pins on your ESC’s?

Could you provide me with some more details on what motors and ESC’s you are using with your copter? One solution would be to change the refresh rate on your ESC’s and tor the timing.

Another solution could be to try change the update rate that pixhawk sends command signals to your ESC’s, this can be found under the advanced parameters section called RC_SPEED, you might want to change it down to something around 100 just to test if this helps the situation?


#7

Hi

Thanks for your reply.

The ESCs are : Unmannedtech 30A Multi-Rotor ESC (simonK)
The motors are Unmannedtech (Brushless Motor 2217Q, 880Kv)
Both supplied as part of 3DR Quadcopter kit.

I’ll look into your suggestions regarding changing the update speed this evening, and let you know if its working.


#8

Hi

Thanks for your suggestions.

I’m not sure if the ESC’s are grounded.
I’ve connected in the standard way for the 3DR instructions: with all 3 wires in the ESC connected to the distribution board via the plugs on the board.
I can’t really see how this grounds them, relative to the Pixhawk (which is what I guess you mean), but I assume that they’re grounded via this distribution board in some way.
How can I check? (I have access to a cheap digital multi-meter)

I tried reducing the RC_SPEED parameter, as you suggested, but if anything it made it worse :frowning:


#9

I did not realise you where using the 3DR PDB so if that is the case, you will have a 4 wire cable that comes from the PDB to your Pixhawk, and another 2 wire cable. The 4 wire cable is for the signal line to the ESC’s, and the 2 wire contains power and ground. Did you connect them both to your pixhawk?

Otherwise it could be something to do with the timing setting the ESC’s directly that have been changed for some reason. My suggestion would be to set the motor timing back to high.

Also you should try changing the frequency to 16Khz

You can either use the USB-link board to setup the ESC on your comptuer, but otherwise read this guide here on how to program them using the audio tones menu.


#10

Hi

Connections on my Quad:

  1. Main power line (6 wires) from the 3DR Power monitor (BEC?) to the “Power” socket on the Pixhawk
  2. “Futaba” type connector (4 wires) from 3DR PDB to Pixhawk

The two-wire connector (“Futaba” ) type isn’t connected .
Where should I connect this, as it’s described as “Backup power” (or somesuch) in the manuals?

If this is the grounding between the Pixhawk & the PDB\ESCs then that might well be the problem!

If you can let me know how to connect this, I’ll try this evening after work.

Thanks


#11

Yeah that 2 wire cable (black and red wire) has the common ground and also the 5V to power the pixhawk output rail which is not usualy needed. However you just need to plug it into the pixhawk output rail.

  • “Futaba” type connector (4 wires) from 3DR PDB to Pixhawk should go along the bottom rail
  • “Futaba” type connector (2 wires) from 3DR PDB to Pixhawk - red wire is in middle pin, and ground is the top pin.

Hopefully that will sort the problem out, but I also suggest double checking the settings on your ESC’s as the motor timing setting could also be wrong.


#12

Hi

Thanks.
That seems to have improved things a lot. But I’m still getting the odd glitch.

I’ll try your suggestion about the motors.

The links you provide are about the 4 in one ESC.
Are they relevant to the 4 x 30 Amp ones I have?


#13

Hi

I’ve tried again, and the same motor still loses power suddenly.

The symptoms are that it will take off, then fly for about 40 seconds in a stable hover, then suddenly tries to flip. There doesn’t seem to be any consistent reason for this.

I have also tried the usb Link, but that doesn’t work. I’m very reluctant to use the “stick 'n beep” method, but I guess I’ll have to if nothing else works.


#14

Could you please attach the log file of that flight so I can try have a look? Otherwise you might want to have a look at this post to figure out what is going wrong via the logs.

otherwise here is also a great article showing you hot to troubleshoot problems via the logs with your arducopter.


#15

Hello

OK I’ll try to get the log file.

Unfortunately I’ll be away for a week or so, but I’ll post the log when I’m available.

Thanks


#16

Hello Again

I have a suspicion that the problem might be to do with a very poor GPS signal where I live.
Although I got a green light, it was borderline between seeing 5 & 6 satellites, and I suspect that the "glitches I* experiences might have been related to this.

I’ll experiment further at locatio9ns with a stronger signal…


#17

That could cause a problem. If you want to attach one of your log files here I could have a look to see if there are any of the more common issues.

But if you feel its poor GPS signal do you have any other way to verify that its not just some inteferance, or something wrong with the actual module? Is the area you are based known for poor GPS reception?


#18

I looked at the satellite acquisition information via the telemetry , and also realised that the Pixhawk was often reluctant to arm.
In my original flight location I frequently got 5 sats. Moving to a higher area (I live in a steep-sided valley) I could reliably get 7 sats.
With regard to “interference” I’ve moved all the ESCs from the original location sandwiched between the body plates under the Pixhawk, and placed them on the arms . Hopefully this will reduce any interference a bit.

Unfortunately bad weather stopped play before I could try a test. I’ll wait for a dry day and then see what happens. If there are still problems I’ll share the logs and see if you can spot what has happened.

Thanks again


#19

I’ve now attempted to fly taking more care with the GPS signal. It’s now showing constant “Green”.

I’ve had a brief look at the logs from a flight, in “Stabilize” mode (No GPS?) and I still get the same random Power-loss\flip effect. I can’t make head nor tail of why this is, so I’ve attached the log for your perusal.

Thanks in AdvanceLogs.zip (141.8 KB)


#20

Sorry about the long delays in getting back to you about this, but I just wanted to follow up to see if you ever figured out what the issue was? After looking through everything again, and looking at other related issues it might be a problem with your GPS module causing something strange. Have you tried to do a hover test without your GPS module connected?