Picture from cam but No OSD

I hope it is just me not doing it the right way…
I have the iflight succex micro f4 v2 tower and i have no OSD information in my goggles…

  • I tried changing between pal and ntsc to see if that would help.
  • The tower is connected with fixed connectors and i made sure that no pins were bend.
  • The IRC Tramp is connected as it should (i can change channel through betaflight) so i know that works as it should.
  • OSD is turned on in betaflight
  • I tried different versions of BF software for the flight controller to see if that made any difference, but that didnt work.

Unfortunately i cant find much information og the tower and i am a little lost here….
I tried for 3 days straight now to make it work, but nothing helps.

Maybe im just stupid and cant see the problem. :slight_smile:

Anny Ideas???

are your sure you have the osd uart set

Are you thinking about the settings for the pin outputs in the cli ?

The vtx and fc are made with connectors that can only fit together in on way… so the hardware should be fine. Unless it is doa. :grin:

sometimes 1 uart is use for the on board OSD so on your ports tab 1 uart may need to be set to config/msp ( thats 1 uart and not uart 1) donot change usb/vcp.
cannot say for sure your FC needs this done as some do some dont worth a try though.
also maybe silly question the vid from cam is going through FC isnt it.

Yes. Cam is connected to fc, and vtx to fc.
I wont mess with the usb. Tried that once. Wont do that again.
Ill take a look at the uarts… but i dont think it is the problem.
I have the usb and 2 uarts, one for the reciever and the over is supposed to be used with IRC Tramp.

at a loss then, ive also looked at the wiring diagram and it not clear, maybe ask on manufactures web site.