Omnibus F4 V6 - Motor 4 on inav


#1

Hello Guys!
after running the F4 V6 for some days with Betaflight 3.5.1, I switched over to inav 2.0.0.
But, motor 4 does not work properly with inav. In the “Motors” tab, I can start the motors as usual, but motor 4 starts not before 1470. From this level in, it seems to react very agressively.

Configuration:

  • Omnibus F4 V6 (Unmannedtech, some weeks old)
  • Racerstar REV35 BLHeli rev16.5
  • inav 2.0.0, inav configurator 2.0.0
  • Sorry, I cannot upload the dump file as a new user. I paste it here, if someone needs it.

What I have tried:

  • memory erase during update, default in CLI
  • switch back to Betaflight: motor 4 works
  • Multishot, Oneshod, Detault: all the same
  • tried version 2.0.0 and modified version from
    I2c magnetometer not working on Omnibus f4 v6
    -> the same
  • disabled all serial ports, soft serial etc: the same

Can you help me?
Thank you!
Bernhard


#2

I am not familiar with inav as if I need it’s functionality I find ardupilot much better and they now it also support a few of the omnibus boards too, but sadly not the omnibus f4 V6.

That said you can connect to your esc via blheli suite or configurator and check the settings on ESC 4, or change the protocol to pwm as inav does not support dshot yet at the moment (I could be wrong about dshot)


#3

Thank you, Alex.
I double checked my ESC settings, all ESCs switch between the different protocols automatically. I checked oneshot125 (which should be equal to PWM) on Betaflight and inav; the problem remains. The same error if I control the ESCs with BLHeli suite via inav.
Everything worked fine with Omnibus F4 V3 and inav 1.9.0

Thus, the FIREWORKSV2 tarkget obviously is buggy in inav 2.0.0; I did not find an issue in GetHub.
If anyone knows a workaround or when a solution is planned, I would appreciate.


#4

Hi Bernard,
You did calibrate the esc’s? This is as noted required for inav atm.
Regards, Andrew


#5

Hi Andrew,

I just wanted to update the thread with exactly the solution you proposed.
Of yourse, I had calibrated my ESCs, but I destroyed this during the analysis with BLHeli suite. Finally, it was Konstantin from the inav crew who convinced me that this must be the error after all the there and back with Betaflight for cross-check.

Sorry for being late and causing you unneeded effort.

-> inav 2.0.0 and the binary from “fat” / Andrew linked above work without problems.

Best regards
Bernhard


#6

Hi Bernard,
Great that you resolved the problem.
Regards, Andrew


#7

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.