No power when connecting SPF3 via battery


#1

I know this page was about SP Racing Evo but and since Evo and Deluxe still use the same base board, I need your help with SP Racing F3 Deluxe.
When I plugged SPR Deluxe to Cleanflight Configurator, the respon was OK. But when I connect the lipo, Cleanflight Configurator cannot communicate with the board.
This stopped when I unplugged the lipo.
Why is this can happenned? Is there some jumper pin or anything to enable it?
I once read that maybe there was shorted pin and I already check, the pins were ok.
I use SBUS with this FC. When I unplug the port, the problem still exist.
Is there something I missed?
Please help, I stucked


SP Racing F3 Evo Flight Controller Guide
#2

Sounds like there could be a problem with the voltage regulator. Possibly you did not power it via a 5V supply, or when plugging in your battery there was a voltage spike which blew the regulator.

Do you get any LED when its plugged in via battery, and does it work when you plug it in via USB? If so then its definitely a blown regulator.


#3

I got the same problem with SP Racing F3 Deluxe since yesterday, non light when I plugged from battery, but via usb works fine. Any solution?


#4

Here are some common causes for this problem, which is usualy the solution, but on some rare occasions it could be an actual hardware fault.

  • Are you trying to powering the board via a 5V input pin + GND? Powering by VBAT only will not work - it’s just for measuring the battery voltage.

  • Have you checked continuity from their 5V supply to the 5V input pins on the board? Check GND on ESC/PDB to GND on FC and 5V on ESC/PDB to a 5V input pin on the FC.

  • Have you checked for short between 5V and GND on ESC/PDB?

  • Take a photo of a multi-meter measuring the 5V output from their PDB/ESC - i.e. is it actually outputting 5V?

  • Have you measured 5V at the INPUT pins on the board? - measure between 5V and GND on the board itself, not at the PDB/ESC.


#5

BAM fixed. I had the same problem. How I fixed was i ran 5v directly from the pd to my pwm. It then ran power thru the back door of the fc. I hope this works it did for me!!!


#6

Same Problem. This board has worked previously just fine. Funny thing is the LEDs show 5v and they are powered off the FC, evidently there is 5v working fine on the board with no short. When plugged into a computer by USB the board runs just fine, if I connect a battery and then unplug the computer it still works just fine. However I cant get power into the board when I just use a battery. The 5v rail goes into a spare ESC 5v connector. Any help would be appreciated.


#7

Hi. I have the same problem. Everything works fine with usb connected (arm the motors with the radio, etc, etc). When i turn off the usb cable and keep only the battery, the controller appears to turn off. But still have the receiver and the Matek on. I’ve powered the sp-f3 thru the 5V bec of the Matek, and power the receiver using the throttle cable (black/red/ white).
What exactly do you mean (Stanicus) when powering thru the back door of the fc??? Thank you!!!


#8

I have a pwm receiver. So i hooked 5v from the pdb to the receiver and it powered my fc. The other way is to take the 5v and connect it to the fc where you plug in your esc for your motors. Just make sure you have your positive and negitive correct.


#9

i have a pwm receiver too and have already tried the two options you told, but without success. I am wondering, as a last option, if i can use a 5v bec from the battery to the usb port?! i could make an usb cable only for power. When Using usb from other sources plus the battery the boatd works fine. but i’m not shure if i can use this from the same battery!??


#10

Are you sure you are getting 5v from the bec? All in all, on your fc. Anywhere it states vcc and ground. You can connect your 5v to to power the fc. Well all but the buzzer and vbat. But most power it up from the esc output headers. I wouldnt try to connect from the usb port.


#11

I had the exact same problem - it was caused by a defective pdb that didn’t provide correct voltage to the f3 Evo. The bad pdb was the RealAcc XT60 Hubosd Eco. I switched out power boards and all works just fine. I bet Stanicus is right on and you should check your power to FC…


#12

I have the answer you all have been avoiding… The board is fired. These are cheap pieces of shit but experience is the key. The voltage regulators on these are junk, but there is a fix. You can install a capacitor to act as a surge protector to prevent a voltage surge from frying the board. But if you’re on this thread, chances are it too late. These are boards are cheap, Amazon Prime has them for $23. Suck it up, get an new one, and install the capacitor directly to the the PDB. There are better FC’s out there with these built.