SP Racing F3 - Status LED (red) won't blink if connected to battery

betaflight
flightcontroller

#1

Hi everyone,

I’m a newbie. I just finished building my own quadcopter. I used SP Racing F3 FC and flashing betaflight.

When I tried to arm the quad, I couldn’t when only the battery was powering the module. However, when the quad is connected to the PC via a USB cable, and if I entered motor test mode, I could arm the vehicle.

Then I noticed that when only the battery powers the quad, only the blue LED (the power LED) of the FC is ON. The red LED (the status LED) doesn’t blink at all. It only blinks when I connect the FC to the PC.

I disconnected the FC from the PC, measured if the FC gets 5v from the PDB, and I found it gets the 5v.

What can be the problem?
Please help.


#2

i have a spare sp racing f3 and have just tried to replicate your fault, powering up from different locations but couldn’t get the red LED not to flash.
if it flashes for you with usb power we can assume the led is working.
do you have RC input movement on the receiver tab in betaflight?
The latest version of betaflight doesn’t fully support the F3 board, try a older version, eg 2. something not 3. something.