New VTX killed my FC?


#1

so i just got myself a matek vtx, i hooked everything up - got video it was all good. battery works and the escs beep, i remember plugging the FC into the pc to activate the camera on UART 3 in cleanflight - it connected all fine, so after everything was set up i went for a test flight and my transmitter did nothing. so i was puzzled.

tried to put it back on the pc to figure out what went wrong and found that the USB says USB device descriptor failed.

ive tried everything, cant flash the FC in cleanflight because it cant find the boot loader, cant flash it in demonstrator GUI because it goes non responding trying to find the FC. Zidag doesnt work because it says the (USB device descriptor failed) in the drop down, and but when you try to do USB serial it fails to install.

Im stuck for ideas. im thinking i might just have to buy a new FC :’(


#2

Could you give us some more details on what FC you used? My initial guess is maybe you had too much stuff connected to your FC, so the internal regulator burnt out.

If this is the case you could may still be able to connect to your FC via USB, but it will not turn on via battery power.


#3

i think its just a clone board tbh, just shows up as an F3 in cleanflight.
all ive got hooked upto my FC is the 4 motors and the VTX

i am connecting by usb, both lights are on the fc - bluer and blinking red but im just getting a usb error in device manager

fyi battery also works


#4

this is what im seeing in zadig btw. also notice in device manager its got the yellow ! on what should be the VCP


#5

okay so this is starting to annoy me. its powered up on battery, everything is on, the VTX has full signal and im looking at it now through the monitor.

No idea what so ever why the FC has decided to stop talking to the PC

Edit: while digging ALOT online to find the fix on the problem, i ordered a new data cable as i found alot of discussions where the cable was the problem. I have multiple cables, but only one is a data cable, the rest only provide power and no signal.

Ive also ordered myself an F4 FC because why the hell not :smirk: either way if the FC is fixed with a new cable, it will turn into a spare


#6

your right about the USB cables.

There is more than one type and there is no real way to tell them apart.
Some only do power
Some do power and data

Some only support 1Amp current being pulled through while some will do more.
For things like phone charging.

Glad you found your issue and your back and working.


#7

Yeah, so i got new data cables, turns out its the FC. Good job i ordered a new one.

No idea why it stopped working its so odd