New build, couple of issues

miniquad

#1

Hi Guys,

New here, hoping someone could offer me a little advice.

I’ve built a Lumenier QAV210 / Full naze32 / Emax RS2205 motors / Little Bee Pro 20A ESC / FrSky 9XD Trans / X4R-SB Receiver

I followed a build guide to set up the naze32 in base flight that seems quite good

I’m aware things need tuning but I was hoping this would at least to get me up and running
Only settings change were ‘motors idle on arm’, set receiver to CPPM and set up the radio type. I calibrated the ESCs (Set master slider to max, power on, then move slider to zero)

I’ve got two issues that so far I’m not sure about

  1. Using no throttle curve it almost takes off with just slight throttle. With the motors spinning at minimum it’s beginning to think about moving.
    (I have created throttle curves, these make no difference). At 0 throttle stick the motors are stopped. I saw a min throttle setting in Baseflight (exact wording escapes my memory), is this what I need to adjust.

  2. This is the move serious issue - there is a lot of vibration. With no props it’s fine, with props on you can see it juddering at hover. I’ve tried another set of props, no difference. I’ve checked the prop balance and their fine - stationary at any point I turn them to.
    I’ve run one prop at a time, no real vibration until high throttle - which is maybe partly due to the fact I am holding is stationary.

I’m at a complete loss with this - any help would be very gratefully received.

Thanks in advance


#2

Just to update - I decreased the min throttle setting, not tried with props but that seems to have lowered the speed the props spin, did another re-calibrate as well.

Noticed also at max throttle (1850) one or two motors don’t quite spin at that rate, maybe 60 - 60 slower, this is constant throughout the range on throttle travel.


#3

This is actually a PID tuning issue, you should lower your P gain slightly. Someone has a similar issue and I spoke abit about basic PID tuning - Naze32 rev6 quad oscillating after lift off

Sound like maybe your propellers are not mounted correctly (are you sure you are using the correct shaft spacer to ensure they are exactly in the middle of your motor shaft? Are you sure the motors are mounted properly and dont have a bent shaft? You could also try to balance your propellers as a last resort.

Hope that helps, but if you still have issues let me know and we can gelp get it sorted for you :slight_smile:


#4

Hey Alex,

Thank you so much for taking the time to respond. I will check out the PID link you shared.

Regarding the props, they do seem to be balanced (admittedly a bit of a home made balancer) but they stop at any point I move them to.

I shall check the motor shafts in detail this evening.

The motors are mounted straight to the frame (no spacers/ adaptors etc …). I did put a couple of washers on each bolt as the supplied bolts were very very close to the copper winding inside the motors (good job I checked), but these are on the bottom side of the frame, so shouldn’t affect anything. The motors line up perfectly with the holes in the frame, sit flat, and the bolts are snug (finger tight then a bit more, maybe 1/8 turn).

However, as suggested I will check this again.

Prop mounting - here you could be onto something …
The props come with no adaptor rings, they just fit straight on - however, I noticed that two of them were a very snug fit (need gentle wriggling to install or remove) whereas the other two were ever so slightly looser - not rattling around loose, but can be removed with no resistance compared to the other two >>> I have a few packs of these, so will sort out x4 blades that all have the snug fit and try this,

The supplied prop nuts (M5 nyloc) are quite large, as they have a flange. I bought some spares (that a friend uses with no issues) - they are also nyloc, but do not have bottom flange so are lighter and smaller - I’ll give these a go as well and report back this evening.

Once again, thank you for your help and expertise, it is very much appreciated - hopefully I will be flying soon.

Martin


#5

Hi Alex,

Thank you for taking the toime to respond, much appreciated.

I shall check out the link re. PIDs and adjust as you suggest - thank you.

Regarding the motors, they are mounted direct to the frame, sit flat and the bolts are ‘snug’ - fingertight then maybe 1/8 turn. I put a couple of washers on each bolt on the uderside as the bolt ends were very close to the motor windings. I shall re-check the motor mounting though, just in case. I will also check the motor shafts this evening.

Re. prop fitment, you could be onto something here …

The props have no adaptor, they just fit straight on, but I noticed that two are a snug fit such that you have to gently push them on/ pull off whereas the other two just dropped straight into place. I don’t remember that there was any noticable movement, but I would need to recheck. I have a few packs so will see if I can get x4 snug fits and see if that makes a difference. I’m kinda hoping the motor shafts are all the same size as that is another possibility …

Also, the supplied prop nuts were quite large, with a bottom flange and not particularly well finished. I bought some M5 nyloc spares from a hardware store (as used by my friend with no issues). These are slightly smalled external diameter, no flange, and are lighter - I’ll try these as well.

Hopefully one of the above will resolve or narrow down the issue, it would be nioce to get the thing flying …

Again, many thanks.

Martin


#6

Hi Alex,

I’m fixed … :0) This is what I did:

Installed Cleanflight and recalibrated motors
Set the min/ max on the transmitter to 1000 / 2000
Set the Min Throttle to 1075
Max Throttle to 2000
Min Commnad to 1000 (default)
Enabled Oneshot 125
Dropped Looptime down to 1200

A quick test hover above the bed (just in case …) and it’s complety vibration free and flies beautifully.

The Looptime was suggested on the multirotor.uk forum (I posted my issue up there also).

I need to drop the p-gain slightly as you suggested, couldn’t fit it all in - I’ll research how to do that and shout if I get stuck (probably simple, but not done it before),

Many many thanks for your help, really appreciated.

M


#7

Happy to hear you got it sorted :slight_smile: and thanks for sharing the solution too.


#8

You are more than welcome - not sure exactly which change fixed it but hopefully this might help someone else. Just flew it, completely stable, hovers almost ‘hands off’ - very happy with that.

Just need to sort telemetry and buzzer out now …