Need help problem solving my drone issue

After a flight yesterday my drone stopped working and I’m having trouble figuring out what the issue is, I thought it might be the PDB, but now I’m not sure. Details below, any help is appreciated.

The issue: I have a Matek F722-STD running on Betaflight 4.04, this board has a separate PDB with 5V running to the FC. When I plug in a LiPo, I hear the first 3 beeps from my ESCs, but I don’t hear the other two that usually follow. I can see an LED light up on my FC and also 2 on my Rx, but I get no indication that it is connecting to my Taranis, and I have zero telemetry. I am unable to arm, and there is no video transmission. … Then, when I disconnect the LiPo and plug into my computer via USB, the lights on my FC and Rx come on again (different light pattern though), no ESC beeps (which is normal) except now, I do have Telemetry and I can verify that the Taranis is connecting. … If I add the LiPo on while the USB is plugged in, I hear the 3 beeps from ESCs, but I don’t get any other functionality, and I am unable to make the motors spin up in Betaflight.

My thoughts: I initially thought that maybe the PDB was broken and it wasn’t transmitting power to the FC, but the FC and the Rx both lit up, and ESCs did initialize with 3 beeps. A multimeter shows 16.8 Volts across the ESC leads, and I was getting anywhere between 3.6 - 4.3 volts across different parts of the FC and Rx. So now I’m thinking that maybe the FC might be broken, but I can still connect to Betaflight no problem and I get telemetry when plugged into USB, so I have no idea.

Backstory on the flight: It was a gentle flight with a few tumbles from close to the ground, no broken props or any visible damage. However, after I landed at the end I noticed that the battery cables came loose and were slashed by the props at some point in the flight, however, I’m not entirely sure when it happened and it may have kept flying normally after that because it never fell from the sky, I manually disarmed at the end. Testing the battery seems to show that it’s okay, no shorts or anything, but I’m still taking safe precautions. However, it was immediately after I disconnected this pack and tried to put on another that the quad wouldn’t arm and these issues started, so I’m not sure if something might have shorted from the battery thing, or the final drop from the disarm shook something loose.

I’m not sure what’s wrong and I’m out of ideas to test and try to see what’s wrong. Does anyone have any thoughts on things I can try to test and isolate the issue? I am happy to buy and change out components if need be, but I don’t want to change out the whole FC and PDB only to find it wasn’t necessary or it didn’t fix the issue.

I really appreciate any help. Thank you

Welcome to DroneTrest dronesco

To be clear, when you plug in the battery with no USB, do the lights on the FC come on?

If no, check the connection cable between the flight controller and the PDB. The loss of the last two beeps means the esc’s are not getting throttle connection from the Flight Controller. This is usualy either loose or damaged connection between the FC and the PDB, or a blown 5V rail on the PDB.

Disconnect the pdb from the fc and test the voltage over the 5v out pins from the PDB. Anything there? Be really careful doing this you dont wanna short anything over any of the other pins.

@DoomedFPV is the Matek meister - any advance on this Doomed?

no not really.

It does sound like an issue as your not getting the final beeps on the ESCs.
If your using a ribbon cable check it over and re seat it

Thank you for the responses.

When I plug in a battery with no USB, one red light comes up on my FC, and one light half comes on (with USB both red lights shine strong and a blue light blinks). And my Rx, which gets power from the FC, comes on as well with battery alone. I also am not using a ribbon cable, I have the FC attached to the PDB from the 5v pins from the PDB.

I ended up contacting Matek support to see what they thought and they told me to check the resistance of a 0 ohm resistor on the PDB and I found 47 ohms across it. The told me to bridge the resistor with some solder, but I was out of flux and it’s tiny and I wasn’t able to get the solder to really adhere. I’m ordering some more flux, and will try again, but now when I plug a battery in, the 0 ohm resistor heats up, starts smoking and shorts. I’ll contact Matek again to see if bridging the resistor is still a viable option, or if the board is toast now.

Any chance your motor screws are shorting the stator to the frame?

Just to be clear which PDB are using (are you talking about the matek FC HUB?). From past experience the ESC beeps corresponds to a motor protocol your using which I am aware you already know. Is your flight controller still working or was it toasted?. If you still have access to betaflight then just go to the modes tab and see if the ARM command work by flicking your ARM switch(no lipo connected). Lastly a Ohm resistor seem to be is replaceable by a piece of wire or even a solder blob. I also suggest watching drone mesh’s video on fixing/troubleshooting FC boards.

Sorry I haven’t responded in a bit. I decided to order a new soldering iron as the one I had seemed really inefficient. However, after everything I think I may have shorted something on the PDB. But it’s odd, when I test for continuity with my multimeter I’m getting no continuity, but every time I plug in a battery with my smoke stopper, the light on my smoke stopper goes off right away. So, somehow it shorts only when current is flowing through the system. I’m kind of new to soldering and all this stuff and I’m a bit at my wit’s end with all of it, I likely going to just order a new PDB and have to disassemble everything and redo it all. Hopefully I don’t mess everything up. I appreciate everyone’s help.

Benjo, I’m fairly confident the issue is in the PDB and not the motor screws, but how would I test for that?

Mark, the flight controller seems to work fine, I can plug it in with USB and the receiver binds, I can open betaflight and see everything working, it arms, but the arming action doesn’t translate to any of the other components. I watched drone meshes videos, but the 0 ohm resistor on this board was so tiny and in such a crowded location that I had a ridiculously hard time trying to bridge the two sides, and I think I shorted something on the board in the process.

Hi there, so a little update. I bought a brand new FCHUB-6S and changed out the old one, which I thought was the issue, and I am still having the exact same problem. When I plug in the battery with a smoke stopper, the smoke stopper turns on right away. I also don’t get any bad continuity from any positive/negative terminals I check. When I plug in, I start to hear the 3 beeps of the ESC’s but as the smoke stopper lights up, the beeps get quieter, as I’m assuming the smoke stopper is taking all the power. So there must be a short somewhere… right? Unless I made an error installing the FCHUB, I don’t think the issue is in the PDB. Also, when I plug the Flight Controller in through USB, it still powers up just fine and I am able to connect RC and access betaflight and all that stuff. Do you think there is an issue with the Flight Controller? Or maybe another component? I also have a capacitor on there, could that be the issue? Or camera/Rx/VTx? I’m a bit disheartened after buying the new PDB and spending all day changing it out just to find out the issue is still there. I’m hoping I don’t have to go around changing every other component just to find the issue.

Any thoughts or recommendations?

your drawing current through the smoke stopper when the motors beep.

If you don’t get any continuity beeps and the smoke stopper goes out after the startup.
You may be fine.
As long as your smoke stopper isn’t bright ( full on ) you should be good to go.

post a short video if you can.

Thank you, I did learn about the smoke stopper lighting up with the beeps while working on this quad, unfortunately that isn’t the issue here. I believe the issue has to do with the FC and the VTx. Here is a video showing the details of the current issue:

To elaborate on what’s going on. After changing out the FCHUB, I started disconnecting things one by one, and after disconnecting the VTx, the quad seemed to be fine. I assumed the problem was with my Tramp VTx, so I bought a new VTx. Today, I soldered on the new VTx, and there has been no improvement, it’s actually worse. As you can see in the video, with the VTx attached, I hear one motor beep and then the stopper goes off and no other beeps or anything, the motors never engage with the FC. However, simply unplugging the VTx, allows everything to start up smoothly with no issues. The wiring is all still attached, only unplugging from the VTx itself. … It should be noted that I changed out all the wiring when I changed the VTx, so I doubt it’s something there.

My only thought is that somehow the video or smartaudio feed that’s going into the FC isn’t being handled correctly, and that’s causing some issues. Has anyone seen anything like this? Would it make sense to simply try different UARTS, or anything else? Any help is greatly appreciated.

Thanks

you may have a ground loop going on…

Disconnect the the first ground from the left…
The one that is between your smart audio and video

I desoldered the ground you mentioned. It didn’t help. Then I also tried desoldering the Video and SmartAudio wires, to see what would happen, and still the same issue. So the only thing connecting the VTx to the drone were the positive and negative terminals from the 10v pad on the pdb. I also tried moving them from the 10v pads to the main XT60 input pads, and still the same issue. Again, if I unglug the VTx and leave the wires attached, the drone starts up normally.

I wouldn’t think it would be wise, but should I disconnect the main ground from the VTx, and maybe use the other ground (the one you had me disconnect)? Or maybe try grounding it on the FC instead of the HUB? The issue is persisting with just the two main positive and negative wires connected, and the VTx isn’t even attached directly to the FC in any way, only to the PDB, which is brand new.