NAZE32 rev 6 using smart audio and BF script on Qx7


#1

My telemetry output to qx7 is good once armed as normal for this controller, however after installing the chaosfpv and turning on smart audio in betaflight nothing. I mean I still get the telemetry output to controller, but pid selection etc and vtx setting just — next to each selection for value and no option to edit, just reset telemetry .
Any ideas would help as I am bouncing off a brick wall right now :confused:


#2

I think the v1 ChaosFPV VTX may have a bug in them

@unmannedtech can give you better information.

I did read this on unmmanedtechshop.
https://www.unmannedtechshop.co.uk/chaosfpv-vtx-t-video-transmitter-25-800mw-7-24v-betaflight-telemetry/

Please note, that Smart Audio on this VTX does not work in Betaflight 3.3 out of the box, you will need to use butterflight, or wait for Betflight 3.4 to use smart audio with the VTX. Otherwise this VTX works just like any other and has an LED display to change channel/power levels the old way.


#3

I did read that, but none of the editing is working for betaflight from controller, is that also part of this bulletin?
Its installed in my blade 220 and the led is not visible, just button as the local fpv racing now want 25mw for racing and randomly assigns you a channel, So I wanted this for ease
which ironically I just bought from unmannedtech shop


#4

@Jesse_A_Livengood

Why not just flash Betaflight 3.2.5 for now… that will give you the functionality you need until its fixed


#5

betaflight, is that the flash version, if so i am using the 3.2.0
still no dice :frowning:


#6

Can you show us a screen shot of Betaflight configurator. The Ports Tab.


#7

It should work on UART2, but I myself have not used a naze board for about 2 years now so I dont know for sure. My only suggestion would be to double check the port settings in betaflight so that you have set smart audio (and nothing else) on UART2. I assume that the OSD is working fine, and you can access the OSD menu without any issues before you try to connect smart audio?

Also now that I mention that, I have not tested if smart audio works with a non betaflight OSD setup. Which OSD are you using with your naze32? As I beleive it needs to be a betaflight OSD, not a multiwii OSD for smart audio to work.