Chaos FPV VTX osd issues


#1

Hey folks, little bit of an issue with my Chaos FPV VtX … when i plug in the battery the flashing led says i am on F 4 (with 3rd power option (200mw) selected) but when i go into the osd on my goggles i am on a completely different channel and down to 25mw … do i need to configure anything in betaflight to get the FC OSD to go to F4 200mw ?

Cheers


#2

When you change channel to a different channel and power setting on the VTX

Does the information on the OSD change to something different?

Just wondering if the OSD is displaying the wrong information or default information as its not reading data from the vtx


#3

Im sure its the osd not reading the VTX settings on startup. Just dont know how to solve the problem. I dont have to change the channel on my goggles everytime i start it up so i assume that it is on channel F4 (my preferred channel btw :joy:). But i always go into the osd to change everything JUST IN CASE lol

Just want it the FC to be on the same page at start up.


#4

Going to give this a try after work and see what happens …

Betaflight CLI VTX commands


#5

The LCD menu is kind of separate from the smart audio menu, so if you change the settings via the OSD/betaflight and apply them it should be correct. If not please let me know so we can look into this further.


#6

Right - as it stands i turn everything on (power up quad, goggles and transmitter) … i have video through my goggles and when i go into the OSD > Features > VTX SA (no options in this menu) but in VTx TR the default settings are BAND:BOSCAM A, Channel :1, power: 25

When i change the settings and save, then go back into the menu they are still changed so all is good there, however when i unplug battery the settings are all lost. Like i said though each time i plug in the battery the VTX led screen is showing F4 / 3 (power 3) … no idea why it doesnt store the settings in the OSD menu.

I have tried setting the VTX_BAND = stuff in the CLI tab

Stumped here lol


#7

OK so as it seems the osd isnt talking with the VTX - any changes i make in the OSD do not affect the VTX in any way. I have it connected to UART6 (T6 port on my Hobbywing xrotor FC) and tbs smartaudio is enabled in the ports section of betaflight - from what i can see it should all be working. I can access the OSD menu but it has no effect on the VTX ??? Very peculiar :thinking:


#8

Hi guys,

i have the same problem. I tried with a minicube f3 fc, on urt and on softserial led pin too, none was working, in the osd menu does not appear as smartaudio. Im using betaflight 3.4.1


#9

Hey there. Well i solved the problem by crashing the quad and having to replace the VtX anyway lol … not much help im affraid but bought the same one and now the osd is working perfectly … might just be a bad batch so could only suggest trying it in a different quad to see if the issue stays then if it does i suspect a faulty VTX.


#10

Thanks for the update


#11

Hi all, our Chaos VTX on the current BetaFlight versions may require that you use the AKK & RDQ patch to run correctly. The Betaflight Devs have said that they’re going to include the patch in a future release so that you don’t have to manually select it. If i completely misinterpreted this, let me know!