My mates a tool - reset wizard X220s factory reset all settings

Only got my wizard x220s last week rtf (first real drone) upon arrival all worked great. Along came my friend who’s been flying a while who told me he could tune it up by tweaking the settings on beta flight so took it away only to return it to me all completely factory reset. I’ve seen how to flash it and set up on youtube but they are for the wizard x220 will it be the same for the x220s or Not??? Thanks in advance

If I recall correctly the PID’s on wizard X220s are just stock anyway… it flies well enough on stock settings. But if you are a more experienced pilot you will probably want to fine tune them to your feel.

However we wrote a setup guide for changing some of the stock settings to get the wizard 220s working better. Its aimed at beginners, so you will probably skip a bunch of things but hopefully it will help you get it back in teh air again… if you have any specific questions I should be able to help. :slight_smile:

http://blog.dronetrest.com/wizard-x220s-initial-setup-guide-in-betaflight/

Cheers Alex
I’ve been trying to ring today.
Will I have to 3rd install ports and flash it first because like I said it Been completely reset or should I be able to just follow your link and go from there
Thanks alot

Did you manage to get it sorted? If you have any specific questions just let me know here or on the blog post.

About the calling, best to send an email/live chat as we hardly get a chance to answer the phone right now. We are working towards getting someone to be on support full time, but now we all do all the jobs so can’t always be around to answer the phone… #smallbusinessfun :-p

I just got my x220s in right outta the box I couldn’t get it to bind by after doing a bunch of research I set the controller the way online manuals tell you to output mode ppm and sbus and set my switches got the new a8s receiver to blink fast try to bind controller light blinked slow than turned everything off than on again and still the rc jut says binding tried a little bit of things I seen on the web and for the life of me this rc won’t bind to my quad now if I power quad light blinks slow turn rc on without binding and it stays solid i gathered that is correct as far as the quad goes but still can’t get rc to bind