MinimOSD 1.2 com port failed


#1

Hi, around two weeks ago i bought from you a MinimOSD v1.2 to connect to Pixhawk.
After i tried to open with Minimosd extra with FTDI via Arduino, and i got the famous message “failed to talk to bootloader”, then i switched off to try again.
The result was : error opening com port.
I searched a lot through forums, and i found in yours a topic with similar problem.
I soldered an USBasp to ISP pins and tried to Burn Bootloader with these settings:
Arduino Pro or Pro Mini (5v, 16MHz) w/ATmega328, and got this:

avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: programm enable: target doesn’t answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

The board had both leds on and one yellow blinking, I checked again the connections, but got same problem.

Please help


#2

Looks like the atmel processor has been fried :boom:. Did you solder the bridge connectors on the top and bottom of the board?


#3

Got free time finally!
I reburned bootloader with usbasp, and the osd extra finally worked, but when i plug the wires to transmitter i see only super-disturbed camera feed without letters/numbers, if disconnected the camera signal back clear.
Tried 5v, 12v, but nothing. Miniosd extra seems to work and saves data, but no way to get it work.
Feel sad about wasted money and time (a lot of time) :frowning:


#4

How are you powering the osd?

That is the best way to power camera and VTX separate from osd and only connect video in/ out and gnd to the osd