MinimOSD - failed to talk to bootloader


#1

I recently bought the Minim OSD V1.1 for ArduPilot Mega from you when I tried to use the config tool I get a ‘failed to talk to bootloader’ error?


#2

It seems that there is a problem with the bootloader for your minimOSD (as the error message suggests ) :stuck_out_tongue:

A simple solution would be to simply burn the arduino bootlader back onto your MinimOSD board. I recently wrote a quick guide on how to burn the arduno bootloader onto one of our brushless gimbal controllers, so you can follow the bootloader guide here

The only difference will be that you will need to connect the USBasp to the ISP pins as shown below.

Once arduino is open

Select Tools > Board and select your board (for minimOSD select Arduino Pro or Pro Mini (5v, 16MHz) w/ATmega128)

Select Tools > Programmer > USBasp

Select Tools > Burn Bootloader


#3

Hi. i did exactly what you say and have all driver up to date for USBasp but in Arduino i always get this message:
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: programm enable: target doesn’t answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

one thing i cant find in Arduino boards is: Arduino Pro or Pro Mini (5v, 16MHz) w/ATmega128)
It only has: Arduino Pro or Pro Mini (5v, 16MHz) w/ATmega168)
Any clues?


#4

I suggest that you first double check that your USBasp is connected properly and making a secure connecting with the minimOSD board. If you did not solder the ISP header onto the board it might be a good idea as it then ensures a proper connections.

As for the board selection in the Arduino IDE, choose Arduino Pro or Pro Mini (5v, 16MHz) w/ATmega128)

Hope that helps


#5

I did exactly what you said and It worked for me, perfect thanks a lot.