MinimOSD - cant see OSD information on video


#1

It seems that the MinimOSD board is working because I see the OSD flight informations and everything works getting data from the APM2.6 if the camera is not plugged in.

If i plug the camera i see the video but the osd informations don’t overlay on the video.

Camera video wire and all the rest is wired as per instructions and schematics on APM website. (see picture below)

Camera has the video and ground wires only, not 12v. since it has it’s own battery, (GOPRO) Can you tell me what could be wrong?


#2

Firstly, if you did not purchase an official minimOSD then the board could be faulty as I have seen that a bunch have the wrong crystal on it, but from your problem is sounds like the board it atleast working because you have some data on the OSD screen overlay.

Can you please double check everything is connected properly as shown below for gopro cameras that dont need power.

First check if there is a problem with your camera/receiver

  • Try to connect your camera directly to the receiver to see if that works. If it does not then try another camera/receiver as that is where the problem is.
  • Double check that the cables have a good connection.
  • Also try to change your camera between NSTC and PAL and make sure MinimOSD is properly configured for PAL/NSTC (see below on how to do this).
  • Once everything is on, try to reset the minimOSD via the reset button.

Changing MinimOSD between NTSC and PAL

Setting video mode (NTSC/PAL) is done through the OSD Config Tool. It can be set in the “Video Mode” menu as shown below. After changing this option don’t forget to do a “Save current tab to OSD” in the configuration panel, so MinimOSD EEPROM is updated.

If your camera works, try to update minimOSD CharSet

You might also want to try to update the CharSet - instructions here, take care to make sure the board is supplied with exactly 5V during update as it can be abit sensitive to that.

Defective and fuzzy chars are the result of a faulty character updating. Max7456’s internal memory is really picky about voltage level during a charset update. Usually it happens with some PCs with lower USB voltage. The only way to fix that is updating the charset by feeding the board properly. Just making sure it has around 5V there. E.g.: tying the two stages and feeding it by an external battery on the video IO pins.

To upload the Charset:

  • Connect your FTDI Serial adapter
  • Select the correct Serial COM Port on the bottom of the screen as shown below. The COM port for your minimOSD might be different.

  • On the menu, select Options > Update CharSet.

  • Select the desired .mcm file from your PC and press Open.

During the update process the board will reset, and if its connected to a monitor it will go black after showing the initial bootload screen. This process should only take a few seconds.


Missing OSD output on Falcon 250 Prod (SP F3 controller)