Mamba F405 Flight Controller wiring to FrSky R-XSR


#1

Well the dislike and frustration of Diatone products continues to build. This time with the Mamba F405 Flight Controller.
I’ve wired it up to a Frsky R-XSR receiver which is bound to my Taranis X9D+ (works ok)

As you can see from the above diagrams it connects to the PPM.
Betaflight is set up as an SBUS receiver but I get zero signals from said receiver to the quad.

Anybody else had experience with this flight controller and wiring it up to an SBUS receiver? Or can anyone suggest an approach for diagnosing the issue?

Thanks in advance :slight_smile:

Bigger picture here: https://www.diatoneusa.com/store/p590/Mamba_F405_Flight_Controller_Betaflight_STM32_MPU6000_OSD_Built-in_5V/2A_BEC.html


#2

assuming sbus set in ports tab and config tab.
1st make sure r-xsr is not in ppm mode to test this just change to ppm on FC save and check receiver tab.
2nd try different uarts in ports tab as different firmware might use different uarts as sbus input.


#3

you could also try to move receiver wire from ppm to the rx1 just below


#4

Thanks Dale for the tips. Tried moving from PPM to RX1 just below - nothing.
R-XSR not in PPM mode.
Will try the different UART ports - good thought! :slight_smile:


#5

hope it helps Big Cheese


#6

The car outputs inverted sbus so you can’t connect it to any rx. This is why most FC have a dedicated sbus pin as it has some extra hardware to invert the signal.

When I get a chance I will check the pinout as it should have an inverted sbus input


#7

of course forget about inverted signals bummer. all else fails put r-xsr in ppm and try.


#8

R-XSR put in PPM mode and haved tried all UARTS in Betaflight; nada. You see why I hate Diatone!


#9

Just had a light bulb moment the xsr included wire is incorrect and not clear in the instructions.
use the 5 pin plug ground and positive then the 4th wire is sbus.
if your using the included plug with 3 wires it aint never gona work.
just a thought.


#10

Dale - good idea - I’m using the 3 wires so that would explain a lot. Just off to get my soldering iron out. Will report back shortly (fingers crossed)


#11

Dale - you’re the man - exactly that - five pin connect with 4th wire worked a charm.
Thank you for the solution. To say I’ve been swearing a lot at Diatone has been an understatement! :slight_smile:


#12

Smashing, only had the light bulb moment as i was looking for a camera wire in my spare box, found the rxsr three pin wire and realised the trouble i had, then thought eh i wonder!.
glad its sorted BIG CHEESE .