Kakute f7 current sensor issues

f7
kakute
holybro

#1

Ive owned several versions of the kakute fc’s and have never had this issue. So I just bought the kakute f7 and started calberating the current sensor in betaflight then I ran into a problem. When I look at the amps in the osd it’s backwards. When I lower the throttle current goes up and raise the throttle current goes down. Any ideas? Faulty board?


#2

Ummmm ok…
That’s a new one on me :confused:

Maybe the scaling is wrong…
@UnmannedTech guys have you seen this before?


#3

That is super weird and I dont know off hand what it could be… are you by any chance using a virtual current sensor selected by accident? Or have you wired the current sensor the wrong way round?


#4

Negative on all of that. Everything on the quadcopter works great except the current sensor.


#5

I’m wondering if you have a faulty board then and there is some sort of short that causing it.

Its strange that it changes with your throttle input that’s what makes me think its faulty.


#6

Yeah that is quite strange… did you order it from us? If so would be great if you can send support an email along with a video (or you can add it here to the forums) so we can talk to Holybro about this as i have not seen this issue before.


#7

No I didn’t order it from you. I ordered it from Amazon but not sure about what company. I guess I could contact holybro directly. It isn’t a huge priority that I have current reading or mah just a wierd thing that I’ve never seen before.


#8

Try to go back to the seller through amazon.

If you find the issue can you comment it here.
I would like to know what the cause is.


#9

Just wondering, but do you have a high amp draw as soon as you plug in your battery ?


#10

i have the same issue with the kakute f7. i know higher volyage equals lower amperage, but i didnt think it reflected in how much throttle is applied/


#11

I have a kakute f7, with a 4-in1 BHeli-S ESC. The esc has a current sensor, but I have wired it up to the “I” pin in the connector and don’t get any values. Has anyone else tried this or is everyone using BLHeli32 with the curent reading giong into RX7?