How to fix a bricked DJI Inspire 1 battery


#1

If you have somehow managed to brick your inspire battery due to a firmware update, my first suggestion would be to contact DJI support, but if you need it fixed urgently, or no longer have a warranty (after 3 months) here is a quick guide that should help you fix your battery by resetting the internal battery firmware, thanks to Lynh Phan for the tip!

Please only attempt this if you are confident with hacking/tweaking stuff and make sure not to short any wires as this could permanently damage your battery or worse!

  1. Carefully detach the battery’s top cover – a fine knife or flat head screw driver will allow you to easily unclip the cover.
  2. Gently disconnect the balance plug / loom to the IC. Let it sit unplugged for 60 minutes.
  3. Reattach the plug / loom.
  4. Fully charge your battery and do two full cycle at low level hover.
  5. Condition your battery and you are good to go.

This should reset the firmware and your battery should now work.


Dji phantom 4 battery not working
#2

Alex - need to make clear that removing the white top involves separating latches in six spots around the case … not just the two at each end … Have to separate the lid-like edges from the black case in four more spots … a spatula works best … I tried your suggestion on my “Bad Battery” which was 8 months old, charged twice and never flown … Took a charge fine, but came up “Bad Battery Cells” … no help from DJI … “buy a new one”!! After following your instructions I still got a “bad battery” warning and could not operate the Inspire … I left it running until the batter ran down, recharged it … and will follow up if that works … FliteDoc


#3

Thanks for pointing that out, and hope that you can get it to work. I have not tried this recently and it could be that a recent DJI firmware update could of stopped this from working. I dont have any damaged batteries to test this on, but hopefully you can let us know if you can get it working.


#4

Well, after following your procedure, the Inspire booted up OK, but still got a “Defective Battery Cell” warning on FreeFlight, and could not operate the drone … I let the battery completely discharge w. the Inspire just idling (about an hour!) and then charged the battery … and then got the same warning when I booted up the controller, FreeFlight and the Inspire … :o( Pretty poor factory support when you have a battery that has only been charged once and never flown turns out to be faulty … even if it is 6 months old … At least they could have asked to have it sent in to determine the problem, and possibly sell me another at a discount …


#5

Sorry to hear that did not work out, and I do agree that it is annoying that you only used it once, but since its after 6 month period you get no more help. Not sure where you are based, but if you are in UK or Europe we have some inspire 1 batteries TB74 / TB48 if you need any?


#6

Thanks Alex … unfortunately I’m in the mountains of Wyoming!!

Someone should look at setting up a service to repair these batteries!


#7

Hello FliteDoc, if you still have that dud battery lying around, please can i buy the circuit board from you? I bricked my circuit board while trying to hack the inspire battery to replace the battery part with a tether, my cells are fine , i just need the circuit board part.
Ill pay shipping and for the board.


#8

Do you still need the board? I have one from a TB 47 that won’t respond anymore.

Richie


#9

My TB47 was completly dead it wouldnt charge or come on at all.
This is whati tried, I opened the battery disconnected the board from the battery. I cheked the voltage and it would indicate 0.6 volts.

There is a thick red cable(+) pole ,
and there are two thick black wires one connects to the Charger to the Board with the LEDs
on Top and the Other on connects that same board with the LEDS to the Cells.
I Jumped those two Black wires by temporarily welding another thick wire from the end of the black cable from the that bring the (-) pole from the Charger to the (-) pole that goes in to the cells
This way I Bypassed the board and feeding 26 volts in to the cells.
I did this intermittently checking the voltage on the cells about every 3 minutes, making sure the battery didn’t overheat.
The voltage at the beginning was 0 volts then it started climbing to about 5-6 volts then 10-12 volts, then 15-20volts, and finally to about 23 volts. I let the battery cool down for about 15 min in between every 3 min charge, the charger and battery would get warm.
Once the cell had charge I reconnected the upper board to the cells, and I pressed the on button on the Flight battery and it went on the started charging by it self and working normally. the charge on the battery only went up to 3/4 full indicated by the lights.
Have not had a chance to test flight with the battery or a change to update the firmware on the battery.