Dji phantom 4 battery not working

phantom

#1

Hi,

I had two of DJI Phantom 4 battery in non working condition. Since it was pointless to send it back to DJI , so I took a chance to open it and see , if I can fix it.

I found the cells inside completely drained. I desoldered the intelligent board and charged the battery with external LIPO charger. The cells are in good condition.

I also checked the cell capacity by cycling them and found to be 90% ok.

After this I connected (soldered the main intelligent board wires back and also the balance connector which goes at the centre of the PCB.) the board and tried my luck.

Surprisingly the LEDs on the front did turn on but the battery did not output the power to the drone. The on-off procedure is perfectly alright and it also shows the capacity to be full.

I removed the battery from drone and checked on the back connector. It is not giving the power output to the drone but does show the LED indication as it is working alright.

Anyone know what should be done or have I missed something or done wrong ? Anyone has an experience doing this ?

Regards
SID


#2

Sounds like e reasonable fix attempt but I ink the smart firmware recognises when a cell is damaged and then prevents the battery from being used for safety reasons so you will need to somehow wipe that

Might be a longshot but you might want to try update the firmware on your phantom as part of the process it will update t firmware on your smart battery too.

You can also attempt to remove/detach the pcb from the battery for a few hours (the smart part of the battery) as if its anything like the older batteries is will reset the firmware as trhe circuit will run out of power as discussed here

But I have never tried for a phantom 4 battery :frowning: so let me know if anything works

Also when you power your battery on, have you tried to measure the voltage out to chrckchrck if the battery firmware it actually preventing any power to be sent to the phantom?


#3

Hi Alex,

Thanks for your kind inputs and sorry for the late reply.

I have done following. Please find my inputs below.

  1. The cells are in perfect condition. I charged the cells with balance charger (I had one more bricked battery so I used that connector to connect to the balance port of the charger).
  2. I have also done the cycle test of battery , found to be 95% of the capacity.
  3. The total battery voltage are perfectly alright as it should be.
  4. I also removed the balance connector and main two power cable and let it sit for 24 hours , hoping a reset but still the same result. There is no output but the light indicators appears normal on the front.
  5. How do I update the battery firmware if the same battery if not powering up the drone.

Though I will try to externally power the drone with the battery inside and try to update the firmware.

Will update you. In the meanwhile if you find anything on the wrong track , kindly let me know.

Hoping to find a solution to help benefit the community as well.

Regards
SID


#4

I dont have much help here as I have never repaired a phantom 4 battery, but looking around removing the power from the PCB for an hour or so should still reset the smart circuit, so possibly in your case the circuit itself has been damaged or something. Sorry I cant be of more help, but please do share if you find a solution as many people will find it helpful.

I dont know how to update the firmware on the battery itself, other than upgrading/downgrading the firmware on the phantom. But you make a good point that if the battery is not powering the phantom you cant actually update the firmware… :stuck_out_tongue:


#5

Did you find a solution to this problem, other than using the external power to power up the drone.


#6

I gave up and purchased a new battery as mine was kind of old anyway