Help with quadcopter


#1

Hey, so I am new to building drones and I am almost certain everything I have done so far is correct. My problem is that I can only spin up the motors from my transmitter if the flight controller is connected to the computer. My receiver is getting power when it is unplugged from the computer, so that’s not the problem. I’m using a Flysky FS-I6 and a FS-IA6B receiver. When the drone is powered from the battery and I turn on the transmitter, it justs beeps and says the Rx has no power, even though the Rx’s LED is on. I also realized that when I turn on the transmitter, I lose connection to my FPV system.
Flight controller: Omnibus F4 V1.1
Vtx/rx: Eachine 700TVL 1/3 Cmos FPV Transmitter System 148 Degree Camera Module With 40CH Transmission
Any help would be appreciated!
To add onto this, the drone works completely when connected to the computer, but as soon as it is unplugged the transmitter beeps and the Vrx loses signal.


#2

Give us a COMPLETE run down on ALL of the hardware (FC, ESCs, etc.) and what firmware you are using.

If you can, post some pictures of how you have things connected.

Posting a video on youtube can help too.


#3

Im using an Omnibus F4 v1.1 FC, Makerfire 20A ESCs, Flysky FS-IA6B receiver, Flysky FS-I6 transmitter, Eachine 700 TVL transmitter/camera and a 3s LiPo. I flashed the fc usng Betaflight with Omnibus 3.1.7 firmware, I originally tried to flash it with OmnibusF4 and OmnibusF4SD, but neither worked. I received this error message “Error: Supplied image is larger then flash available on the chip! Image: 305.7 kiB, limit = 256.0 kiB” when trying to flash those firmwares.


#4


Here are some images as well as the video I posted above


#5

Ok so I figured out that my fc wasnt getting enough power to power itself and the receiver. I changed where the power was coming from on my pdb and that solved it.