Help with problem diagnosis - two motors running at same time

Weird one here, and I could do with some help on how to best diagnosing the problem. I’m using a used Kakute F7 AIO board on a new frame (DoomedFPV - it’s awesome!!!) However upon building, motors 1 and 2 spin if you apply power in Betaflight in the motors tab. I can’t see any obvious issues. I’m using BT4 with Kakute F7 firmware. Even tried downgrading to 3.57 and still the same problem.

So any suggestions on how I should go about diagnosing this problem, and has anyone come across this before?

BTW - the frame is really awesome. A lot of thought has gone into this frame!

Thanks buddy i’m really glad you like the frame…

Check the signal wires don’t have a short you can use a multimeter to check.
They could be shorting under the board

Spot on! That was the problem - needed the magnifying glass to see it, but wire was just touching the telemetry pad.

One step closer to flying that frame now :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.