Help - TBS Oblivion Video with lines


#1

Last time I went flying I went to try the TBS Oblivion. However, the Fatshark Goggles video feed had horizontal feeds across to the point I couldn’t really see where I was flying. Once back home, I’ve changed the VTX cable, the camera, reflashed the TBS Core Pro, then the flight controller firmware. All with zero luck.
Oh yes, and tried reducing the power and changing the VTX antenna along with antenna lead.
Before I contact TBS, I just wondered if anyone else had come across this, or can suggest something else I can try?

Photo attached is from another monitor, but it shows the exact same problem I was seeing in the Fatsharks.


#2

its your camera

it looks like your on the right VTX channel and the OSD is clear.

Theres something wrong with camera.
Have a look at its connections onto the board.
You could try soldering it directly to the VTX…
The OSD will disappear but your be able to see if your camera feed changes


#3

Probably should have said its the TBS Powercube so an all-in-one so no connections to the board.
Tried a different camera plugged in and same issue. I’m wondering if the FPV Vison part of the powercube is fubar


#4

maybe

Can you just swap out that module? or is it a whole new cube?


#5

Could swap out that module, but it’s $99 +P&P + Tax to see if that’s the issue or something else :frowning:


#6

Only $149 for a whole new powercube as well


#7

ouch… thats an expensive test.

you could email TBS and ask them.

They may be able to give better advice it may be a known issue


#8

That was my next plan. However shall we say that my experience of TBS is of customer anti-support.


#9

Did you buy it from us? But if not, I am still happy to offer advice and can help (as a TBS dealer) when you are talking with them if they give you any issues.

I assume you have that issue before the motors are spinning? And what happens if you try running on a lower voltage battery like 3s? But I suspect maybe the voltage regulator non the fpv system is having some issues. Assuming it’s still under warranty and you don’t have any obvious signs of a bad crash TBS /retailer should offer a replacement to you.


#10

Hi Alex, yes - bought from you guys - order no 48440; back in April.
The issue occurs as soon as the Oblivion powers on, and it passes all the self-tests with no errors.
I’ve logged the issue with TBS to see what they come back with.
No 3S batteries to try I’m afraid. Only run 4S