Need help with TBS Crossfire

tbs

#1

So bought the TBS Oblivion - nice quad, along with the Crossfire TX bundle; comes with Nano receiver. All that blurb about a beginner taking 5 minutes to build it without any drone lingo - utter rubbish. I’ve just finished building a F450 drone from scratch so I thought a little BS Oblivion would be a piece of cake. Oh how wrong can you be. Piss poor diagrams, very little info on how to connect the crossfire nano to the TBS power cube on the Oblivion.

So after burning up one nano (too much soldering gone wrong) I’m thinking of going for the micro reciever rather than nano. Does anyone here have any guidance/good videos/documents on how to connect these bloody TBS bits of kit as nothing seems obvious.

Ok rant over :slight_smile:


#2

Hey Frank,







You can connect your Receiver to the Receiver Port on your Powercube (I think UART 2).
If you have Problems especially with tbs Crossfire (Due to its hype at the Moment there are like thousands of tutorials out there) you can just “ask google” or search at youtube for a Tutorial. To the most parts there are very detailed manuals which can hekp you a lot.
Please consider uploading a Build Log so we can se how you get on with your build.

Luca :slight_smile:


#3

Thanks Luca, I’d had a look at those videos and basically “Huh?” Problem I’m having is just basic connectivity in terms of wiring the Nano to the cube. There seem to be so many options on how you can connect the Nano and then connecting said Nano to the cube. I think if I’d chosen any other drone I wouldn’t be going crazy.

Good suggestion about the build log. I’ll do that. At the moment I’ve given up on the Nano and gone for the micro v2 rceiver instead. That looks like it’s just a case of plugging the RX into the power cube with the associated cable. Now that I can do! :wink:


#4

Hi
Page 39 of the Crossfire manual (rev 7 Nov 2017) gives you the wiring for the micro receiver, just ignore the bits you are not using.
HTH
Cheers
Steve :slight_smile:


#5

Problem solved! After much conversation with TBS Support (not a great deal of help) of having the RX and TX just flashing away green, I decided to put the RX in boot mode. This didn’t do much. I then downgraded the firmware on the TX to the oldest version on the TBS agent. At this point it recognised the RX and upgraded it. Once this was done, the TX and RX Micro binded. I then reset the TX to use open region and upgraded the firmware to the latest version - all good. Tried with the Nano RX and all good again.

So not sure which combination fixed the issue, but we now have one TBS Oblivion waiting to go flying! :slight_smile: