Crossfire not working on Beta95x V3

Hi I just got round to adding my reciever to the 95x v3 . It’s a crossfire nano and I used a four pin hat . It has bound and has telemetry and yet there’s is no response to the flight controller . I’ve tried everything . I switched the nano to the spare uart 1 and also tried another nano reciever and same thing. I’ve checked the output map was correct and switched the rx and tax wires over. I also have tried inverting the uart in cli. Still nothing. To test the jst connector I even tried my frsky Xm plus . That binds ok and I got it working but it cuts out every 10 seconds or so and loses bind! I’ve never had this problem before on my other builds and seeing as though there’s less soldering I thought this would be easier! Oh I also changed the solder connection on the board when I tried both too. Is there anything you could recommend I try ? I have no idea why it’s not working

Could you possibly provide a clear image of the wiring / hat, and screenshots of both the ports tab and the configuration tab in betaflight so I can try to get this sorted for you ASAP?

Thanks for your quick reply . I’ve uploaded the pics. Don’t pay attention to the wire colours as that was the way they came on the four pin jst connector so . I’m really scratching my brain on this I can’t see what can be wrong . Hope you can help. I’ve tried everything I can think of including switching the rx and rx wires over . I’ve tried another crossfire nano too.



Thanks for that!

It all certainly looks correct - there’s a couple of last things I want to check - when you’re testing the radio, do you have a charged LiPo connected to the quad or are you using USB power only?

Does the FC seem to power up okay from LiPo aside from this - e.g. all 5 beeps play?

Finally, have you tried / would you be happy to try and reflash the board entirely to setup from scratch, in case of a firmware issue?

Right I’m so sorry for all the trouble I’ve been . Someone suggested something which I tried and it has worked. For some reason my micro tx was set to CE region. I unlocked it to open region and the crossfire inputs then started working. Strange as it worked on my other quads with the previous settings. But I thought I’d let you guys know in case it happens to someone else.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.