Help me.....STM32 Bootloader

firmware
zadig
drivers

#1

I tried to use the impluseRC but it just says its searching and searching.
In my device manager it says I have SILCON Labs cp210x usb uart bridge…

it does not show the STM32 Boot loader device within the device manager. because I tried to follow the update the drive…

ive tried so many things to get this to flash… I still cant get the latest version on clean flight to connect. BUT I was able to get it to connect with version 1.2 something… but even then I still cant update the firmware. I also tried that Zadig and when I list all devices it shows the USB UART driver. not the stm32 driver… any ideas? are you close to Cincinnati ohio and up for a challenger lol?
dean


#2

also is there a place I can download this stm32 bootloader?


#3

You might want to try flashing the firmware .hex file directly via stm32 dfuse demonstrator software… there a a bunch of YouTube videos showing how to do this as it’s relatively easy to follow. Let me know if that works or not


#4

that’s what I ended up finding a video for and it seems to of worked. I have the latest version of CF installed and firmware.
but the Magnetometer wont show up in cleanflight. its grayed out…any thoughts?


#5

Do you have a Mag. on the board?
Some boards don’t, as external mags are getting common now.
What board do you have?
Cheers
Steve :slight_smile:


#6

As Steve said, maybe your board doesnt have one. But if you let me know what board it is, or prefferably send a photo I can see if it has one or not… Otherwise you do need to enable the mag setting within the configuration tab in betaflight/cleanflight.


#7

i sent 2 pictures. hope this helps. I dotn even know if I need this. I bought it as a kit. every step of the way has been some sorta ordeal… anyone need a quad kit? ha ah


#8

while I’m at it. and you two are the only ones on here. what’ s an ok radio to use… id like to get one at the local hobby shop or if you know of a good cheap one from china…


#9

I’m probably being thick …
but where did you upload the photos, I can’t see them
Cheers
Steve :slight_smile:


#10

I pressed reply to this email… do you see an attachment


#11

I am not sure if attachments work if you use the reply by email feature, best to do it directly on this site…