Dead Beecore FC Board? Hot when battery plugged in (USB fine), no Betaflight connection


#1

Hi guys,

I’m excited to get into FPV flying. Decided to go with a whoop style micro drone, plus some sim practice before getting involved in a larger quad.

Setup
Picked up a FlySky FS-i6X transmitter, a Beecore V2 flight controller (with built-in FlySky receiver), an Eachine ES-02 AIO Camera / VTX combo, and the required motors, frame and props to complete the build.

Unfortunately, I’ve got a problem with the board not working as expected and I’d really appreciate some help from the community with what to do next.

I’m not great at soldering, but managed to complete it reasonably successfully, I hope. I split the video connector on the VTX so have a separate video in and out as the Beecore supports OSD and I wanted to get that.

After soldering the camera and power harness to the flight controller board, I plugged in the USB connection and all the lights successfully turned on.

Problem
However, I didn’t get any confirmation from Windows that a USB device had been plugged in. No standard “Diing” noise, nor is it picked up anywhere in device manager. Naturally, it’s also not recognised in Betaflight either with the “BEtaflight failed to open serial port” error.

I’ve tried downloading additional drivers from ST.com for a STM32 virtual com port driver to no avail. I’m using Windows 10.

Then I tried to plug in the battery to see if the correct current (in case USB was unregulated) running to the board would help it. As soon as I plugged in the battery (a mylipo.de 255 HV battery), the board became immensely hot with a slight burning smell, so I quickly unplugged it.

In the process of testing, I unplugged the camera (of which the power connector uses a 1.25mm socket), and tried powering from battery again. In this situation the board lights up and runs without overheating at all. The moment I plug the camera back in, the FC board gets immediately hot.

Summary
So,
Camera plugged in, battery power = Overheating FC
Camera plugged in, USB power = OK
Camera not plugged in, batter power = OK

I’m so confused… I made the assumption that as I’m getting power to both board and camera, that all should be working and my solder joint was poor. So I re-soldered a few times, and even changed the power cable connector to a different one (that was included with the Beecore), to no avail.

Caveat:
One thing I’m concerned about is that I may have killed either the flight controller board or the camera/vtx board… When I originally wired up the camera, nothing worked when supplying power. I read somewhere online that the EF-01 camera (predecessor to mine) was wired with reverse polarity, so I rewired the power cable for the camera backwards and it worked after that.

Is it possible that I killed the board when I provided power with a reversed polarity power connection on the camera? If I have fried the board, is that just the main FC board, or would the camera be damaged too?

I’m so close, I can connect my goggles and I saw an image from the camera, but just won’t work as expected when battery powered.

Does anyone have any advice? Board was purchased at unmannedtechshop in the UK. Should I get another board and try again?

Thanks everyone,


#2

When you say the board gets hot when connected via usb… how hot are we talking? Too hot to touch the large chip (the MCu). As if it’s too hot to touch sadly the FC is dead :frowning:

If you can add some photos of how it’s all connected we can have a look. Worst case if you did damage it by mistake I will be happy to offer a replacement at cost.


#3

Thanks Alex,

I think you’re right that it’s fried - something on the board is super hot and absolutely untouchable immediately once the battery is plugged in so I’m not sure exactly which component is so hot.

Hopefully the camera is still ok and I can use that on a new flight controller.

I’ve emailed to arrange buying a new board. Thanks again for the quick help


#4

download and run this
https://impulserc.blob.core.windows.net/utilities/ImpulseRC_Driver_Fixer.exe
then try unpluging then pluging in again, if that doesnt work, do it again but continue to flash firmware.


#5

Thanks for the reply.

It’s a good suggestion, and part of my troubleshooting was to download this Impulse RC driver utility and see what happened. When I ran it, it never got past the searching phase though, indicating that windows hadn’t found a connected device.

I ended up picking up a Beta 65S just so I could fly, but when I plugged it in, I had the SAME issue with Betaflight not recognising it.

Just before I pulled all my hair out and reinstalled Windows 10 in rage, I tried a fourth USB cable… and then “ding” - Windows recognised a USB device! Went back and tried with the original Beecore and had the same success.

So, it turns out that I did fry the board (must have damaged a resistor hence the extreme heat), but It was my own fault that the connection to Betaflight didn’t work.

So, if anyone is in the same situation, try all the USB cables in your house. Having acquired so many over the years for charging various devices, I didn’t think that some only transmit power, while others transmit both power and data.

New Beecore arriving tomorrow and now know to reverse polarity, test with a multimeter before soldering and use a quality USB cable.

Guess it’s not a proper hobby until you learn an expensive lesson! :wink: