Chaos 30A BLHeli_32 ESC Telemetry on Omnibus F4 V5

omnibus
blheli
chaos

#1

Hello guys,

I have a build with Omnibus F4 V5.1 + Chaos 30A BLHeli_32 ESC

I’ve updated the ESC to the latest firmware version.

Wiring:
Set J20 on the FC to connect the RX1 to the ESC pins
Connected the T (telemetry) pins from the ESC’s to the FC.

Betaflight:
Dshot1200
Set Ports - UART1 - Sensor Input ESC
Set ESC_SENSOR feature
Choose ESC_SENSOR in Current Meter Source

I don’t get any telemetry, did any of you guy managed to get the telemetry working for these ESC’s?
Any suggestion would be appreciated.

Thanks,

M.


#2

I’m not sure…
But looking at the ESC’s I don’t think they support telemetry.

I see a POS, NEG main leads, Signal and Ground wire… but no telemetry wire?


#3

No telemetry support as there is not a third wire to provide this.

You can however connect to the ESC’s with BLHeliSuite32 using your FC as a passthrough if you need to flash new firmware or config them.


#4

Hello guys I’m using these ESC : https://www.unmannedtechshop.co.uk/chaos-30a-blheli_32-esc/

These have a pin marked as “T” which I guess means telemetry.


#5

@unmannedtech do these support Telemetry?


#6

I only see a signal and ground. If the ESC has a pad for telemetry but is not used, i guess it would be possible but i would wait to hear back from @unmannedtech before making any modifications


#7

Here is a picture of the ESC.


#8

I believe the recent batch we have does support ESC telemetry as I do recall something about this. But I am just waiting on a confirmation from the designer to double check before you spend some time trying to get it working. Sorry I dont have an answer right away as I deal with too many products and get confused between them all!


#10

Just to update you @mrmisu , the latest batch of theese ESC do support ESC telemetry now. So you just need to hook up the T pad of each ESC to the ESC telemetry pad on your FC (or a UART port) :slight_smile:


#11

Hello,

Thanks you for the reply, but as I said in my first post, I was unable to get telemetry from the ESC’s. Is there anything different in the configuration that I need to do?


#12

Yes, you will need to solder a wire to the pad marked “T” and feed that to the esc telemetry pad on your FC


#13

@mrmisu
Have you tried flashing the lastest BLHeli firmware onto them?


#14

Thanks for the suggestions, but I’ve already tried updating and wiring the ESC :slight_smile:


#15

@unmannedtech Alex any ideas?


#16

Can we assume you have checked the following in order?

Connected your flight battery
Plugged in USB to computer
Opened BLHeli suite to read the ESC

Also, for BLHeli_32 ESC’s you’ll need this version to read/flash them http://www.blheli32.com/download-blheli-suite-32-for-users/

Providing your FC is configured for ESC passthrough (which should be by default on latest version of Betaflight), BLHeli_32 suite should see the ESC’s and allow you to configure/flash them


#17

Thanks for the suggestion, but I’ve already read and updated the ESC’s to the latest version, all good there.

I’ve wired the ESC’s T pin to the R1 Omnibus v5 pad, and did all the necessary settings in Betaflight (this is not my first ESC with telemetry) but I’m not able to get it to work.
Mostly I’m curious if anyone from here managed to get these ESC to send telemetry, maybe I have a bad batch or something else that I haven’t thought of.


#18

You need to first make sure the telemetry pads from the ESC are all connected to RX1.

THen you need ot make sure that the solder jumper on your omnibus is correctly set to enable RX1 telemetry as per the image below:

Then you need to exable ESC telemetry within betaflight on UART1… and also make sure you dont use UART 1 for anything else.


#19

good spot @unmannedtech.
I didn’t consider jumpers on the FC


#20

Yup did that (both steps) already.
I have a spare/new ESC and FC, I’m going to do a test and see if I can get it to work like that, maybe I’ve got something wrong when doing the buid…