Can't bind RX4R to X9D (Both on non-EU Firmware)

Hi, looking for some help as I cannot seem to bind my RX4R receiver which I recently purchased.

I am using a Taranis X9D Plus Tx, however, note that I flashed this with non-EU firmware as I needed D8 mode to fly some BNF drones which I have.

I have flashed the RX4R with non-EU firmware (firmware file used is RX4R_FCC180516.frk) but it just won’t bind. LED stays solid red and solid green.

The Tx settings under Internal RF are as follows:
Mode D16
Channel Range CH1-16 (18ms)
When I select “Bind” on the TX, there are four options (Channel 1-8, 9-16 and Telemetry On/Off) and I have tried all four of these options but to no avail.

Appreciate any thoughts.


Have you tried updating the firmware on the Taranis…
Your right they need to both be on non-EU but also the same version.

1 Like

Thanks mate, all sorted. I’m still new’ish to FrSky (liking some of the features!) and I think I got a bit confused between the general radio firmware (DFU/BIN files) and the XJT module firmware (.frk files). I downloaded the latter, flashed it and all is sorted now. Tested my BNF drones too and they are unaffected by the update, so I’m a happy camper.