Can't arm quad in betaflight

betaflight

#21

Propellers are correct, and in proper order, followed arrows on propeller, could it be esc’s, could u tell me how to send picture, at work right now but will do when I get home,


#22


#23

Good build… and good pictures…

Your prop direction looks good. :slight_smile:

So that leaves motor direction to check.

  • Take off your props (please - its for your own safety).
  • connect your quad to BF Configurator.
  • Using the motor tab spin up one motor at a time and check its direction.

image

They should be spinning inwards, the same direction as your props have marked on them.
Also take a note of the speed they start to spin cleanly/smooth.

What motor protocol are you using?
Oneshot, Multishot, Dshot?


#24

Hi, using oneshot 125, all motors in right direction,seems about 1040 smoothly, do you think PID tuning has anything to do with it?


#25

OK

So I’m thinking… ESC Calibration.
Have you calibrated your ESC?

If not watch this:


#26

Hey I’m still here, took your advise with blheli, lots if things I learned, I had not calibrated end points or trim, I think I got esc’'s calibrated except at twitch throttle on motor tab seem to be a click off on master 1 esc, now in sync , 1(blue) 2-4 esc (green) overview all in order


#27

can you post a screen shot.

I think what you are describing is normal.


#28


#29

I still have problem with arm sometimes, I set max throttle 2000, min command 1000 and calibrate channels the same, but won’t arm unless min command less than 1000, see oost


#30

Have you had a look in the CLI to see what your set_min value is set to? I would suggest you set it to something like 1030 depending on your radio throttle minutes value.

Otherwise I suggest you read this


#31

when in betaflight configurator. - On the reciever tab
your throttle channel at zero throttle (stick all the way down) what does it read?


#32

With trottle on zero I reads 1000, range for all channels is 1000 low to 2000 high, stick low threshold = 1015, stick ctr 1500, throttle low had to be 995 in order to arm and it arms fine like this


#33

My problem now is with motor calibration, with drone armed , betaflight motor tab shows with throttle full motors at diff. Levels and none real full, even after blheli shows no errors


#34

If your arming with the Tx and not BF as I cant see the motor/master sliders raised.

Thats airmode taking over the motors.
When using the Tx to arm your quad the PIDs Loop is active as well as airmode.

Thats normal…
Also what will happen is if you raise your throttle to 50/60% and then drop it to 0% your motors will still pick up speed… this is again airmode.


#35


#36

To test the motors/ESC you should not arm the quadcopter. You check the checkbox on the motors tab saying that everything is safe, then you move the master slider via betaflight software to check that all ESC start spinning at the same time.

Looking at the motors with the quadcopter armed is not particularly helpful due to the way the flight controller algorithms work as the vibrations on the desk/workbench mess things up.


#37


#38

Thx 4 ur help, Here’s the probkem, motors humming at full throttle on betaflight, but when props on still can’t get lift . I love this stuff but can’t fly


#39

Just tried hover, no luck but noticed #4 motor sputters with slight delay b4 kicking in, other 3 appear to b doing their thing correctly think I should switch it out?


#40

How heavy is your quadcopter, as 2205 motors should definitely make enough thrust to lift your quad… usually they make around 800g each of thrust?