Can't arm quad in betaflight

betaflight

#1

Even with slider over title, won’t turn yellow, cli says preamp and armstick issue ( stick not I’m safe position) I had it working and the nothing , motors calibrate fine, plz help


#2

Prearm, armswitch issue, range over tit will not arm,


#3

Have you had a look at our betaflight arming guide?

Sounds like maybe your minimum throttle value (min_check) is not correct.


#4

Thank you for your help, I reviewed and have followed all, still no luck, min 1050, max 1990, CPU 8%, constant slow blinking red light, cli says arm switch, I had it work before but no reponse to stick arm now, all receiver channels respond correctly, motor calibration ok, accelerometer calibrated


#5

Throttle low about 900, min check 1050


#6

@blackhawk

just to confirm… your Betaflight configurator - Receiver tab looks like this…

Also how does your arm switch look?


Does the little notch move then you move your arm switch and when its armed does it move into the right section?


#7

Somehow I got range to arm aux1 min 1075 max 1475, but when throttled down motors still going and can’t disarm with stick, this is killing me!


#8

When you throttle down your motors wont stop. If you have airmode enabled for acro flight.

Unless you flip your disarm stick.

Can you get us some screen shots. So that we can have a look


#9

Thx 4 your response, I finally got it to arm by using my channel 5 ( aux1) programmed to switch, I did change small angle from 25 to 25-180 so it would arm in any position, I don’t think I needed to do that and will change back to 25, thx again


#10

leaving small angle at 180 will allow you to arm no matter what angle your quad is in…

Say if your stuck in a tree, your be able to arm you motors and try and bump your way out…
Being careful not to burn out a motor or ESC.

Saved me no end of times.


#11

Thx, I’m sure b I’ll need your help again, this is all new 2 me


#12

Thats what we are here for.


#13

New problem, trottle min ck 1010, when increased to max then return to min value, motor never sloiws down to min ck, so as to land, have to turn it off to stop motors, any ideas? Thx preparing for maiden flight


#14

if you doing this on the bench…
Then its most likey air mode doing its thing.

If you throttle up 50% and then throttle down but the motors still keep picking up speed thats air mode and its normal…
The next step could be a hover test in a safe place.

Before you take it out to hover test…
Please, Please test your disarm switch and make sure your fail safe works correctly.


#15

Ok, working on fail safe now, while working on bench if I hit disarm motors stop immediately, should u setup failsafe on controller or betaflight or both?


#16

Do both.
It takes seconds to setup and could save your quad.

Happy flying :slight_smile:


#17

Thx, hope I’m not bothering you, what is best diy quadcopter for beginners?


#18

Have a look at this.

https://www.unmannedtechshop.co.uk/diy-drone-kits/


#19

Unfortunately maiden flight FAILED, unable to attain lift, I thought if roll, rudder and yaw were neutral applying throttle would lift straight up, it tried but didn’t get off ground, if in air I think roll, yaw, rudder would work, seems not enough power


#20

no lift…?
Check your props on the correct way and your motors are spinning in the right direction.

Take a picture of your quad from the top with the props on.
Front on and Rear on. At a little bit of an angle (Hope that makes sense)

Your motors should spin inwards
image