Cam pad issue on Matek f405 FC

matekf405

#1

Hi all,

Was wondering for some advice please.

Im having an issue were the cam solder pad on the matek f405 FC doesnt give any camera feed to the VTX.
If i twist the cam cable to the VTX cable i can get the camera feed to my fatsharks, but that then means i get no OSD via the VTX pad.

Is it possible, via the CLI to reprogram which pad the VTX pad gets its incoming feed from instead of the cam pad?

Regards
Adam.


#2

There is no way to progamatically (if that is a word) alter what pad the video signal is as that is directly connected to a pin on the OSD chip.

One other thing to double check is that the OSD is actually enabled via betaflight GUI… but if that is enabled then I think that the OSD chip has failed on your FC so you should contact the place you purchased it from to get a replacement/repair.


#3

Thanks for your reply.

Im receiving the OSD fine, its the camera feed that im having issues with.

When the camera is soldered onto the “cam” pad, im getting no camera feed but i am receiving the OSD.

To troubleshoot i twisted the camera cable to the vtx cable, were im getting a camera image but then no OSD because the vtx is then not soldered onto the vtx pad


#4

Hi Addy, did you ever fix this? im having the same problem.


#5

Hi Addy, did you ever fix this? im having the exact same problem.


#6

Use this


#7

I didnt buddy, i just swapped the FC in the end :pensive:


#8

Oh man that sucks, ive already done that to fix other problems, they are too delicate these things. Thanks for the reply.


#9

Thanks ive used that already, everything woked properly last year, take it out now and the video isnt work, it hasnt been touched in all that time.


#10

Ive fixed it!! I was using the 5v pad on the FC to power the camera but i tried using the 5v out on the VTX to power the camera and its working ok, also the ground from the VTX goes to both the camera and FC ground pad, this grounding method seems to

be vital for it to work.


#11

Well done buddy, i gave up on mine haha :smiley::+1:t2:


#12

I almost gave up too, its strange, it worked fine last year wired the proper way, but now I find I need to re-wire everything completely different. Also it says in the manual “try not to power your Camera from the VTX, use the 5v pad on the FC because the ribbon doesn’t like the load” but I have no choice I must use the VTX so its a bit worrying it could fry in mid air.


#13

Some VTX recommend powering your camera from the VTX as the 5v output is normal filtered and can other a cleaning power source resulting in better video.

what VTX and Camera do you have?


#14

Its ImmersionRC 600mW 5.8GHz and Fatshark FSV1207 960TVL camera with clover leaf antenna. Ive just added a DVR recorder to it so it records direct to SD card before it gets transmitted so I dont record the fuzzies, I tried that last year and failed, now I see why I failed at that too.


#15

Same problem here.
camera: this shitty camera from wizard x220
vtx: eachine tx526
matek f405 + matek FCHUB-6S
Fix: connect camera and vtx to same 10v from PDB.