Binding the S801B-D DSM2 DSMX Mini Receiver (F3 SP Racing brushed board)

miniquad

#1

Hi,
I got the F3 SP Racing Brushed controller and the S801B-D DSM Receiver and I am wondering if there is any way to get the bind to stick so I don’t have to bind my DX6i every time I power up the FC.

Any ideas?

Thank you


#2

Check at the minicube F3 guide I wrote as it covers how to bind a spectrum reciever. Essentially within betaflight you need to use the CLI to activate bind mode and then once bound you need to disable it and it will save the bind setting on your satellite​ reciever.


#3

Alex,
Thank you for your reply. I have given that a go but no luck. I still have to bind the TX to the RX every time the FC loses power.

everything else works a treat - it just needs binding every time.

This is what I am using: https://www.unmannedtechshop.co.uk/s801b-d-8ch-ultra-remote-dsm2-dsmx-compatible-mini-receiver
https://www.unmannedtechshop.co.uk/f3-evo-brushed-flight-controller-1s-2s/

I will give it a few more tries… but if you got any more ideas it would be good to know.

Thanks,
Angelos


#4

Another issue I am actually experiencing is that during flight the drone loses bind and falls. To rebind I have to unplug and plug the lipo back in. I tried to record a short clip of the process:

Thanks


#5

I am assuming that after you have bound your radio, before restarding the board, do you go to CLI to set spektrum_sat_bind = 0?


#6

Yep, I have set the bind back to 0. I am setting it for DSM2 bind as that’s
what the Dx6i supports.


#7

My only other suggestion would be to double check you are using the correct bind mode, (DSMX, DSM2 etc…). But to be honest I am not a expert here as have not used spektrum gear for a good few years now. I use Frsky gear myself.


#8

Yeah same here - I think I might need to get the FrSky RX installed and try if it makes any difference.
Thanks anyway - if I get to the bottom of it I will actually let you know.
Thanks