Arming throttle problem Hawk 5


#1

Hi, I just updated my Emax mini magnum 2 stack to betaflight 4.0. When I arm it seems that the throttle value is too high because the drone almost lifts off the ground. The weird thing is that when I flip it into “launch mode” and then arm, there is no problem at all. I have tried setting the motor idle throttle value down to 4% instead of 5% but there was no difference at all. I have also tried to calibrate the esc even tho its a 32 bit.

i have included a video showcasing this problem below, and a picture of my configuration tab.



#2

Sounds like you just need to send your min throttle value to be abit lower?


#3

Just checking I watched the video. Did you say you tried a real flight with propellers on ?
Not in your hand holding it .


#4

I have just tried setting it down to 2 percent, but the same problem still occurs


#5

yeah i have tried flying it, but when i drop the throttle it doesnt fall as quickly as it used to do on a older version of betaflight


#6

That’s most likely due to the improved flying characteristics that come with betaflight 4.0.
Does it not fly well can you get used to it ?
They’re recommending no zero throttle inputs. Except in extreme maneuvers like flips and rolls. Even then they’re recommending we keep our propeller spinning. For smoothness that’s the key to the 4.0 update smoothness.

Another quick question: do you have air mode enabled ?
Maybe you didn’t have air mode enabled before you did the update.
if that’s the case then everything’s operating normally.


#8

@MeatballFreak I’m tracking some reports of things like this with BF4 - are you using default PIDs or have you changed them?


#9

I changed the pids back to what i used before i updated


#10

I always have airmode turned on. I know that you shouldnt have any zero throttle inputs, but the minimum throttle value is still way to high, its like doing a flip without moving the throttle stick at all


#11

BF4 recommends that you use the default PIDs (and re-tune from there) as there are a lot of changes under the hood - I’m guessing your PIDs are too aggressive for the new BF4 code. I’d try the defaults and see if that works.

See here https://youtu.be/3kAdwZMEk8s also…


#12

YES, it finally works
i did as you said and put in the default PIDs and everything now works flawlessly
Thanks!