After first crash motor not working

Hey guys,
after finishing my F405 MAMBA with F40 ESC build, I had a crash with it, now motor number 4 is not working, I hear a beep from the FC and some sort of a sound from the motor but its not spinning, all other 3 motors spin, the core heat is 70C which I dont know if its okay, tried to re calibrate ESC didn’t solve it, any ideas?
Edit:Adding a vid of the problem, if you can sound on to hear the motor and the FC sound.

ummmm could be a couple of things.

First take your props off ( thanks for doing this already )
Use Blheli and see if it detects all 4 escs on your 4in1
If it does check your solder joints on that ESC

If Blheli only see’s 3 ecs then you more than likely have a dead esc

Also you could swap that motor with another and see if the fault moves or stays…
If it stays its the ESC
if it moves its the motor.

Hope this helps.

Great idea, i think I checked it and saw all 4 esc on blheli, ill check it soon again, but its not weird after first crash motor is dead? It wasnt a very hard crash.

Just checked it with a new motor in the same ESC and same problem, so I guess its the ESC? for sure not FC or something?

Flash the esc , check for continuity of esc, if u r lucky things will work

Reflashed all ESC’s, unfortunatley didn’t solve the problem, when I power up motor 4 after few seconds its trying to do something I hear sound from the ESC like its trying to recalibrate itself, then when I lower the power there is another “calibration sound”.
I guess its the ESC? should I replace also the FC just to make sure?

it sounds like you have tried everything…

The only thing left is to try a new FC.

Give it ago and let us know if it fixes your issue.

Interchange the esc or the signal wire