Adding Telemetry to the Walkera QR X350 Pro

multirotor

#103

Hi all, !! I first want to apologize for my English, I’m from Argentina and here we speak Spanish and I am also new to this but I have a question, we might simply changing resistances modify the actions of gps ?, not yet finished the coneccionado, just change the resistance, but the gps does not work. Thanks to everyone,!


#104

where can I get the resistors I need please
thx
jason


#105

Sorry, for to be more clear regarding my question. I changed the two resistors according the instruction, but , then test the quad without connect nothing and the GPS do not work, because do not detect satellites, and the green rigth light never flash, My question is, is possible that the simple change of two resistors make unable the GPS?


#106

With Minim you have to have the telemetry modules connected to a ground station before the data will populate.


#107

I’ve done 100’s of these for people and every single one of them worked. You must have damaged something when trying to replace the resistors. Check with a magnifying glass over everything to make sure you didn’t remove a component or drop a speck of solder somewhere it shouldn’t be.

I’m doing this mod for people that can’t replace these resistors. I have an Ebay listing up and all of the information is in the listing. I have done this mod for 100’s of people so far and all of them have come out perfect. I’m using a laser reflow station to install the new resistors. This insures the board doesn’t get overheated.


#108

Ok, so I have soldered in my minimosd and the telemetry module to the Devo-M and I have sucessfully turned it all on and it is being detected by my android tablet. I have not done any resistors as yet (I might jsut remove the one resistor so USB no longer works, but duplex does).

The only thing I cannot get to work so far is my MinimOSD onto my Devo F7 (using a d-3d gimbal and my gopro 3+ black). Can anyone help?


#109

What is being detected by your tablet? The ground module or you’re connected to the quad and can pull params? I don’t see how without changing the resistors. You can get connected but you wont be able to send anything to the Devo-M without at least removing the 0 ohm resistor next to the Mega32U2 chip.


#110

It’s soo cool! I have the telemetry mod working in full duplex - WreakHavoc in the US has done the SMD soldering job with professional tools.

Can recommend this mod to everbody!


#111

I’m DroneTech here Reinhard! :slight_smile: WreakHavoc on RCgroups.


#112

Alright, got it. And some good news:

Today was a perfect twist: Weather cleared up, winds and rain ceased. I had my first successful Follow Me flight! Always >10 satellites thanks to the M8N GPS module. Tried flying on a different field today (no radio interference whatsoever), and reduced telemetry transmitter power so my tablet’s USB port could manage. It worked like a charm!

Now the real fun begins!


#113

DroneTech and unmannectech thank you for your help with adding telemetry to qr x350 pro. i’ve changed resistor by the connector and the chip. But when i chanegd resistor by the chip, telemetry still wasn’t working full duplex, but it started when i removed 0 ohm resistor. Now my telemetry is working full duplex and i’m happy using droidplanner :slight_smile: Now my qr x350 pro is much more interesting.
Thank you again :hear_no_evil: :smile:


#114

But follow me is not working :frowning: when i turn on the follow me mode, my copter is starting to act strangely. Is it possible that my tablet is not good enough? I use asus fonepad FE170C. It starts acting like there would be interferance in the signal :confused: . It’s not working in tower too. Any idea?


#115

Do you have a GPS module in that tablet? I don’t see one listed in the specs of that tablet. You MUST have a GPS module in the ground station for your quad to know where to fly to. You could have caused a flyaway at least in pitch or roll because you should have also had Alt Hold active. That would at least kept it from going up. But you might be able to get away with a GPS module for any quad like the Ublox 6m or even better is the M8N. You would use a FTDI USB adaptor to connect between your tablet and the GPS module. That creates a COM port for the communicating. I’m just not sure if Tower will connect to it like that. It should be automatic with Android. I just don’t know if the Android will work with a FTDI adaptor. Never tried it. The only other option is they make USB tablet GPS modules and that will work for sure.


#116

Success. Without resistor mod, only one way communication. Which was fine for osd. But in order to get the bluetooth module working properly without disabling usb, I had to swap both of the resistors. This was didfficult as I didnt really have the right tools. Ended up using 660 omh instead of 680 as thats what I had. TX and RX solder pads are indeed incorrectly labeled.

I now have osd, bluetooth and usb working properly all at once. Just wanted to share my experiences :slight_smile:


#117

With a 660 there you may not be able to connect to USB with the telemetry module hooked up. You could have just left that 220 in there because its doing the same thing. The 1k ohm resistor is the one that is allowing you to connect to USB at all and its also why the telemetry is working both ways now.


#118

Hi Akujiwar_Bladefist,

I meet the issue as you.
I need to connect USB to x350pro then run Mission Planner that OSD can get GPS signal.
Could you share your experiences to me?

My Platform info.
Firmware version: x350pro v1.7
Receiver : RX703

Many Thanks


#119

Hi DroneTech,

Do you mean remove 0 ohm resistor will get telemetry working?
Could it have to let OSD working for receiving GPS data?

Thanks


#120

I only use MinimOSD.
I remove 0 ohm. Then put 1k ohm legged wire between Devo-M Tx pin and OSD Tx pin.
This can connect with MP and load parameter successfully.
Disconnect power, and reconnect power, OSD can’t reflash GPS data and voltage.
But if I connect MP once, ths GPS and voltage infomation will show on and dynamic changed.
I think your x350pro had install the rc transmitter.
Turn on rc transmitter will like connect MP once. So, OSD can show every things.
I had modified the SR0 data. So, it just can show [horizon] [real heading] [Flight Mode].
GPS state visible sats gps coord need to connect MP once will show.

I just want to use OSD only.
Could it passible for only OSD build in?
Thanks.


#121

I have friends walkera qr x350 pro Radio control I F7, already has FPV and want to add only mini OSD to distance telemetry, altitude, battery voltage, which procedure, how to do and how to configure, only telemetry. thank you. tutorial could post? diagram. thank you.
Weldas


#122

Hi I just want to install miniosd only to my Walker x350 PRO, do I need to change the resistors as well?
Thanks in advance